Squid as a proxt for SSH connections



  • Now that I have pfsense, squid works great for all my HTTP/S stuff, but just cannot figure out how to proxy my putty SSH sessions through it.  I tried adding 22 under "ACL SafePorts", that didnt help.  Also tried adding 22 under "ACL SSLPorts"

    I used to use openwrt, and it had this ultralight proxy that worked really well.  it was a regular port 3128 proxy that handled all my HTTP/S and also allowed me to use my local putty SSH connections to connect out through this proxy.  So I just cant see squid not supporting this.  But cant figure it out???

    I tried setting my putty client as HTTP SOCKS4 and SOCK5 5 proxy client, no help
    I also tried adding the proxy client, and remote SSH server IPs in the unrestricted list, no help.  at this point im out of ideas as to what to try

    TIA


  • LAYER 8 Global Moderator

    squid is http proxy, while I am guessing you were using Srelay on openwrt which is socks - completely different.

    There is a Srelay for freebsd - if you really want support you could install the freebsd package - ask to get it added to the pfsense repo.

    http://pkg.freebsd.org/FreeBSD:11:amd64/latest/All/srelay-0.4.8b6.txz


Log in to reply