Fatal error: … /etc/inc/xmlparse.inc on line 57



  • Hello!
    pfSense-1.2 running on Soekris box.
    I turned off autonegotiation on two interfaces by putting the next lines in /cf/conf/config.xml in corresponding sections.
                            <media>100baseTX</media>
                            <mediaopt>full-duplex</mediaopt>
    Rebooted firewall and got perfect results these interfaces do not negotiate speed/duplex any more (this was requirement from our provider).
    But now, when I try to delete any Static Route I get this error: "Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 57"
    Any help would be greately appreciated.

    Eugene.



  • I am getting this also on 1.2.1 RC2.

    <media>100baseTX</media>
    <mediaopt>full-duplex</mediaopt>

    Is this a XML parsing issue?



  • @podilarius:

    I am getting this also on 1.2.1 RC2.

    <media>100baseTX</media>
    <mediaopt>full-duplex</mediaopt>

    Is this a XML parsing issue?

    You must have entered

    <media>100baseTX <media><mediaopt>full-duplex<mediaopt></mediaopt></mediaopt></media></media>
    

    at first, then corrected to right format. I do not know how to solve it for now as pfSense apparently 'remembers' wrong format somewhere not allowing new config.xml to be parsed properly.



  • Absolutely correct. I did have it listed as <mediaopt>and <media>on the php close. I have set it correctly and it is working. Sorry about the post when I just didn't double check the settings. Hopefully this will benefit others.</media></mediaopt>



  • my issue is rather different, I corrected it in config.xml but it still does not work (I can not apply any changes through web-interface). This box is located far away - so I was stupid doing that, I am screwed up now -(


Log in to reply