Help with port forwarding Minecraft server



  • I have tried all of the articles and forum posts I have been able to find. I have also tried the PFSense port forward troubleshooting guide. None of the things I have found have helped with this problem.

    I am trying to port forward the default minecraft port to set a server or two up so I can play with friends. But no matter what I try it hasn't reported as being open when I use a port checker.

    I don't know what you guys need to know to help me. but if you tell me what you need to help I will attach it to this post.

    My setup for networking goes like this Modem > PFSense box > Linksys switch > desktop PC.

    I also have a static IP set up for my desktop through the PFsense box.

    Edit: http://imgur.com/a/J9HBB

    Edit2: Also have this posted on reddit. They cought that my NAT should be going to lan, so I fixed that and it doesn't work.

    Edit3: I'm just going to give up. This is way more hassle than its worth just to play a game with a couple of friends. :(


  • LAYER 8 Global Moderator

    "None of the things I have found have helped with this problem."

    So you sniffed on your wan (packet capture under diag) and you saw the traffic when you checked with port checker or not?

    If you say the traffic hit pfsense wan, did you see it go out your lan to your 192.168.1.201 IP?

    The troubleshooting doc if followed pretty much covers all possible steps needed to find out exactly what your doing wrong in like 30 seconds. Pfsense can not forward traffic it never sees.  If it sees it did it forward on - was there an answer?

    If you using your linksys router as switch - why are you even calling out that its a "router"??  So your just using it as dumb switch - its dhcp server is off, are you using it as wifi AP?  Is this IP your forwarding wired  to this switch or wireless?



  • Yes DCHP is off and I'm using it as a wifi AP as well as having my desktop wired into it.
    I went through the doc as most of the posts I saw ended up with a post pointing to it, it didn't help. But I will go back through and try again.


  • LAYER 8 Global Moderator

    First thing to do since your forward look ok - is that your traffic is actually getting there.  So under diag menu, do the packet capture pick your wan interface and put in your port your trying to forward.

    Do you see it hit your wan - if not then its not getting to you and no forward will ever work on that port.

    Does your pfsense wan have a public IP address or is it rfc1918 (192.168.x.x, 10.x.x.x, 172.16-31.x.x)?

    See my example - I don't have that port open, but you can see it got to my wan.

    If you see it hit your wan, then do the same thing on your lan interface (network your forwarded IP is on) Do the test again - do you see it send the traffic to the IP your forwarding too..  These are really step 1 in troubleshooting.  If you see it go out to your IP, does it answer?  If not then either you have the wrong IP forwarded, or its using different gateway other than pfsense, or maybe its running a firewall, or maybe its not actually listening on that port, etc.

    It really should take all of about 1 minute to figure out where your problem is.

    canyouseeme.org is great easy place to test from outside your network for open ports.




  • Its still saying its closed



  • I don't think I'm doing it right. http://imgur.com/a/dFQAS


  • LAYER 8 Global Moderator

    your interface is lan - that is wrong.. Your forward interface would be wan!!


Log in to reply