WAN Specific Quirks



  • Its the dreaded Nvidia 100/10 Mbps PCI Ethernet Card.  I can't give you a model number, because it is allready jamned into a tiny laptop motherboard.

    This card refuses to connect to the WAN, but works perfectly well on the LAN.

    I have tried every single setting combonation possible, but it refuses to maintain or setup a link.

    I have called my ISP, and they said it was the cards problem itself, I tried switching cables, and rebooting everything.

    So it failed to even establish a link with the wan, on the most basic setup of DHCP.

    I tried swapping my WAN interface for my LAN interface, and whamo, it works.

    My LAN interface is not the same NIC, it is a seprate usb attached 100/10 Mbps ethernet NIC, that is some generic brand.

    But for some reason, the new generic WAN NIC only works when I set the setting to forced 100baseTX full-duplex.

    My modem is 1000/100/10 baseTX full-duplex autoselect, so I do not know why it would not work normally.

    There is nothing wrong with the modem itself, I had it replaced with the newest model, and inspected/tested after it had arrived at its final resting place.

    The Nvidia LAN NIC works absolutly fine in auto-select (default), on a 1000/100/10 baseTX full-duplex autoselect network.

    So if somebody could explain to my why this weird behaviour might be happening, that would be greatly appreciated.


  • Netgate Administrator

    Hmm, seems like your modem might not be doing auto-select quite as well as it reports.

    As a test I would try putting a passive switch in between the Nvidia NIC and the modem.

    I would recommend using a managed switch and VLANs over a USB NIC everytime anyway so that could be a solution.

    Steve


Log in to reply