Intel NUC + RTL8169S/8110S/8211 USB GbE Adapter



  • Hey All,

    Reasonably new to pfSense/FreeBSD, so forgive me if I'm missing something simple.
    I've successfully set up pfSense on a series 6 Intel NUC - using the internal NIC for internal traffic and an external USB Ethernet adapter for WAN.

    Everything works perfectly fine… until you reboot the device. Upon rebooting, the USB Ethernet adapter doesn't automatically load (no lights come on and the device doesn't show up in pfSense). If you unplug and re-plug the adapter, it gets picked up automatically and works fine (have to re-connect the PPPoE connection though).

    So to me it seems like it's either not loading USB devices on boot (though keyboard works), or it's not loading those particular drivers on boot (even though the drivers are obviously part of the kernel).

    After a bunch of research, it seems I need to have one of the following in the loader.conf:
    miibus_load="YES"
    if_re_load="YES"

    However, neither of those fix the issue. When booting, I get "if_re doesn't exist" - which from research sounds like if_re.ko doesn't exist - which it doesn't. Though does it need to? Given it obviously works without it - it just doesn't load on boot automatically. I also tried usb_load="YES" though that also made no difference.

    In usbconfig it shows as:
    ugen0.3: <ax88178a asix="" elec.="" corp.="">at usbus0

    When plugging in, I get the following in the system logs:
    ugen0.3: <asix elec.="" corp.="">at usbus0
    axge0: <networkinterface>on usbus0
    miibus0: <mii bus="">on axge0
    rgephy0: <rtl8169s 8211="" 8110s="" 1000base-t="" media="" interface="">PHY 3 on miibus0
    rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    ue0: <usb ethernet="">on axge0

    Any help would be greatly appreciated!

    -T</usb></rtl8169s></mii></networkinterface></asix></ax88178a>



  • PfSense uses a slightly modified loader.conf system compared to stock FreeBSD. If you want to add your own entries to it you have to add them to /boot/loader.conf.local, the usual file /boot/loader.conf gets nuked at system boot and it loses all custom entries you might have added.



  • Sorry, forgot to mention I've already switched to using the /boot/loader.conf.local - same issue :)



  • Update:
    Tried a Microsoft USB to Ethernet adapter, no go (driver from the looks).
    Then tried connecting the AX88178A via a powered USB hub - and it works! During boot it detects the hub, then the AX88178A connected to it.

    Not an ideal solution - I'd be interested to hear other people's thoughts on a possible solution without the powered hub.

    Cheers!

    -T


Log in to reply