[solved] Installation failure, SCSI issues



  • I am new to both BSD and pfSense.

    I downloaded the latest AMD64 USB image and wrote it to a stick, booted, went through the custom install in multi-user mode, and everything looked OK until the actual file writing step. I'm getting messages like:

    Execution of the command
    
    /usr/bin/tar -C /mnt/ -xzpf /distrib/pfSense.txz
    
    FAILED with a return code of 1.
    
    (da0:umass-sim0:0:0:0): CAM status: SCSI Status Error
    (da0:umass-sim0:0:0:0): SCSI status: Check Condition
    (da0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:21.0 (Logical block address out of range)
    (da0:umass-sim0:0:0:0): Error 22, Unretryable error
    g_vfs_done():ufs/pfSense[READ(offset=567148544, length=131072)]error = 5
    
    ./usr/bin/… : Can’t unlink already-existing object
    /lib/libcrypto.so.7: truncated input
    Tar: Error exit delayed from previous errors.
    Exit status: 1
    
    

    So what do you think the issue is here? Flaky USB stick? Flaky SSD? Misconfiguration? Bad formatting? I verified my image checksum after download and it seems to be OK.



  • I suspect that it may be due to the way I'm writing out the USB image. I'm writing it from Ubuntu using dd:

    
    # dd if=/home/gtoombs/Downloads/pfSense-CE-memstick-2.3.4-RELEASE-amd64.img of=/dev/sdb bs=65536 iflag=noatime status=progress
    10832+1 records in
    10832+1 records out
    709894144 bytes (710 MB, 677 MiB) copied, 68.1981 s, 10.4 MB/s
    
    

    After, disktype shows:

    
    # disktype /dev/sdb
    
    --- /dev/sdb
    Block device, size 14.94 GiB (16039018496 bytes)
    FreeBSD boot loader (i386 boot1 at sector 0)
    FreeBSD boot loader (i386 boot2/BTX 1.02 at sector 2)
    BSD disklabel (at sector 1), 8 partitions
    Partition a: 677.0 MiB (709894144 bytes, 1386512 sectors from 0)
      Type 7 (4.2BSD fast file system)
      Includes the disklabel and boot code
      UFS2 file system, 64 KiB offset, little-endian
        Volume name "pfSense" (in superblock)
    Partition c: 677.0 MiB (709894144 bytes, 1386512 sectors from 0)
      Type 0 (Unused)
    
    

    fdisk shows:

    
    Disk /dev/sdb: 15 GiB, 16039018496 bytes, 31326208 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x90909090
    
    Device     Boot Start   End Sectors  Size Id Type
    /dev/sdb4  *        0 49999   50000 24.4M a5 FreeBSD
    
    

    This seems wrong, because the size is definitely supposed to be more than 24 MB.

    When I mount and ls:

    
    # mount -r -t ufs -o ufstype=ufs2 /dev/sdb /mnt/stick/
    # ls /mnt/stick
    bin   cf    conf.default  dev      etc   lib      media  pkgs  rescue  sbin     sys  usr
    boot  conf  COPYRIGHT     distrib  home  libexec  mnt    proc  root    scripts  tmp  var
    # ls /mnt/stick/distrib
    ls: reading directory '.': Input/output error
    
    

    So something is really fishy with this filesystem. What am I doing wrong here?



  • Yet more fishiness:

    
    # fsck.ufs -f /dev/sdb
    ** /dev/sdb
    
    CANNOT READ BLK: 128
    CONTINUE? [yn] y
    
    THE FOLLOWING DISK SECTORS COULD NOT BE READ: 128, 129, 130, 131, 132, 133, 134, 135, 136, 137, 138, 139, 140, 141, 142, 143,
    
    


  • Solved it by using a different USB stick. It's unfortunate, but oh well.


Log in to reply