LCDPROC Service doesn't start when using certain drivers. Need Help!



  • Hello Folks,
    I am trying hard to find the root cause for a weird behavior when using certain drivers on LCDPROC.

    Eg. MATRIX ORBITAL -  Service doesn't start (see image) - I tried several different ports and configuration with NO SUCCESS. I can't find any log regarding the problem. Some other drivers work fine (like Hd44780 with Parallel port), others not. (same problem)
    I am really wanting to make that work as I have a prototype depending on that. I am also considering a "paid support".
    Any good soul to help on that?

    Regards
    Fabricio Guzzy.






  • Are you sure the service did not start? Have you checked with "ps -aux"? Have you checked ALL ports? My port is /dev/cuaU0 and it took a long time to finally find the correct port.



  • Hello Revengineer,
    Thanks for the message!

    Yes, I am sure the service is not started.
    I checked the USB port before and after plug the USB cable. It gets  ugen1.2 (I also tested all the other USB ports)

    Question:  Did you have to install any additional driver for the LCD USB device or just plugged in and start using it with the embedded lcdproc driver?

    Thanks Much!
    Fabricio Guzzy.



  • I would recommend you bypass the pfSense front end GUI for now and work with the command line directly for debugging. Start as user root.

    The lcdproc documentation is here: http://lcdproc.sourceforge.net/docs/current-user.html

    You need to focus on LCDd. Look at options like "-f" to keep the program in the front end, and "-r 3" to start the logging of messages. "-r 4" might work, too.

    You can list all options with "LCDd -h"

    LCDd takes its input from LCDd.conf. Either use the existing file, or create a new local file. Use "-c" to point to it.

    The documentation also lists the specifics for all drivers and their options.

    Once you have all of that worked out from the command line, you can work your way back to the GUI with better information. Beware that if you work your way to a good LCDd.conf file in the standard place, it will likely be replaced at the next reboot, so keep a backup.

    Caveat: either make sure you have no leftover LCDd servers running ("ps -ef" | grep LCD"), or use a new (high) port number for this debugging. Something like "-p 13000".

    Best of luck, keep us posted.



  • Hello FMERTZ

    Thanks much for the tips. I just used the command line:  LCDd -f -r 5 -s 0    and it showed me the problem….
    It seems the FREEBSD is not recognizing my USB display at the plugged port. Anyway, now I finally know what is going on here.
    It seems I have something wrong with my USB ports. Checking now...

    By the way, I have started it (for tests) using a regular COM port and the service finally started. Up and running.

    Thanks Much! Appreciate it!

    Fabricio Guzzy


Log in to reply