Updating pfSense from 2.3.3 to 2.3.4 Broke pfBlockerNG



  • Updated from 2.3.3 to 2.3.4 and now I am getting the following message for all of my DNSBL:

    Unresolvable destination alias 'pfB_Abuse_CH' for rule 'pfB_Abuse_CH auto rule'

    When I went to installed packages, pfBlockerNG (version 2.1.1_8) has a check mark indicating that it is current, but under the description I have the following messages (see attached screenshot):

    Newer version available
        Package is configured but not (fully) installed

    I tried re-installing pfBlocker from the installed packages menu with no change. I have also completely removed pfBlocker then installed it again from available packages and this also did not make any differences.

    I check /conf/pkg_log_pfSense-pkg-pfBlockerNG.txt  (see below) and there are no error messages. Using dig to check DNS resolution for several websites on my black list confirmed that pfBlocker is not working.

    Any help would be greatly appreciated.

    pkg_pfSense-pkg-pfBlockerNG.txt

    >>> Installing pfSense-pkg-pfBlockerNG... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 9 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
            pfSense-pkg-pfBlockerNG: 2.1.1_8 [pfSense]
            lighttpd: 1.4.45_1 [pfSense]
            lua52: 5.2.4 [pfSense]
            whois: 5.1.5_1 [pfSense]
            GeoIP: 1.6.10 [pfSense]
            grepcidr: 2.0 [pfSense]
            aggregate: 1.6_1 [pfSense]
            pecl-intl: 3.0.0_7 [pfSense]
            icu: 58.2,1 [pfSense]
    
    Number of packages to be installed: 9
    
    The process will require 46 MiB more space.
    80 KiB to be downloaded.
    [1/9] Fetching whois-5.1.5_1.txz: ....... done
    [2/9] Fetching grepcidr-2.0.txz: ... done
    [3/9] Fetching aggregate-1.6_1.txz: .. done
    Checking integrity... done (0 conflicting)
    [1/9] Installing lua52-5.2.4...
    [1/9] Extracting lua52-5.2.4: ......... done
    [2/9] Installing icu-58.2,1...
    [2/9] Extracting icu-58.2,1: .......... done
    [3/9] Installing lighttpd-1.4.45_1...
    Extracting lighttpd-1.4.45_1: .......... done
    [1/9] Installing whois-5.1.5_1...
    [1/9] Extracting whois-5.1.5_1: .......... done
    [2/9] Installing GeoIP-1.6.10...
    [2/9] Extracting GeoIP-1.6.10: .......... done
    [3/9] Installing grepcidr-2.0...
    Extracting grepcidr-2.0: ..... done
    [1/9] Installing aggregate-1.6_1...
    [1/9] Extracting aggregate-1.6_1: .... done
    [2/9] Installing pecl-intl-3.0.0_7...
    [2/9] Extracting pecl-intl-3.0.0_7: .......... done
    [3/9] Installing pfSense-pkg-pfBlockerNG-2.1.1_8...
    Extracting pfSense-pkg-pfBlockerNG-2.1.1_8: .......... done
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...
    MaxMind GeoIP databases previously downloaded.
    Adding pfBlockerNG Widget to the Dashboard... done.
    Remove any existing and create link for DNSBL lighttpd executable... done.
    Creating DNSBL web server start-up script... done.
    Creating DNSBL web server config ... done.
    Creating DNSBL Certificate... done.
    Starting DNSBL Service... done.
    Upgrading Adv. Inbound firewall rule settings ... no changes required ... done.
    Custom commands completed ... done.
    Executing custom_php_resync_config_command()...1 table created.
    1/1 addresses added.
    done.
    Menu items... done.
    Services... done.
    Writing configuration... done.
    Message from lua52-5.2.4:
    ===>   NOTICE:
    
    The lua52 port currently does not have a maintainer. As a result, it is
    more likely to have unresolved issues, not be up-to-date, or even be removed in
    the future. To volunteer to maintain this port, please create an issue at:
    
    https://bugs.freebsd.org/bugzilla
    
    More information about port maintainership is available at:
    
    https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
    Message from GeoIP-1.6.10:
    GeoIP does not ship with the actual data files. You must download
    them yourself! Please run:
    # /usr/local/bin/geoipupdate.sh
    Message from pecl-intl-3.0.0_7:
    ****************************************************************************
    
    The following line has been added to your /usr/local/etc/php/ext-20-intl.ini
    configuration file to automatically load the installed extension:
    
    extension=intl.so
    
    ****************************************************************************
    >>> Cleaning up cache... done.
    __RC=0
    
    

    Sceenshot Installed Packages

    See attached.

    ![Screenshot from 2017-06-23 18-58-34.png](/public/imported_attachments/1/Screenshot from 2017-06-23 18-58-34.png)
    ![Screenshot from 2017-06-23 18-58-34.png_thumb](/public/imported_attachments/1/Screenshot from 2017-06-23 18-58-34.png_thumb)



  • @MR2Rick:

    Newer version available
        Package is configured but not (fully) installed

    Those are part of the "Legend"  ::)

    Did you do a Force Update or Force Reload ALL ?



  • Thanks. You are correct, I was confusing the legend for messages.