SG-1000 throughput issue



  • I have an interesting throughput issue here, at least for me.

    Speedtest.net shows 85 mbps

    speedof.me shows 2.5 mbps

    testmy.net shows 2.5 mbps

    When I watch Twitch anything above 2.5 mbps buffers(anything above 480p)

    I can watch HD movies from Google fine

    Now when i remove the SG-1000 from the network and reprogram my wireless access point into router mode or plug straight into my cable modem(only modem, not a router), i get all speed test sites showing me about 85 mbps and everything is fast.

    So is there settings in the SG-1000 that i need to change?  It used to work fine, I tried updating and still no change.

    Any ideas?

    jammcla


  • Rebel Alliance Developer Netgate

    There is not nearly enough information here to say.

    First, make sure you are on a current snapshot Remove and traffic shaping or limiters you have in place for good measure.

    Then go to the firewall address, https://x.x.x.x/status.php and download the file it offers

    In that archive, check "Network-Interfaces.txt" to see if the interfaces show a proper speed/duplex, then look in "Network-Interface Statistics.txt" and see if there are any interface errors. Inside "OS-sysctl values.txt" there will also be some OID entries with statistics for the cpsw NICs which may also show errors. You can also look in "Process-List.txt" to see if anything in particular is consuming large amounts of CPU time.



  • Through the web interface I did update the box to the latest(before getting the numbers in my first post).

    Never used traffic shapers or limiters on it.

    Network interfaces showed 1000 full duplex

    No Ierrs or Oerrs

    I brought the box into work and did some testing.

    Speedtest.net shows 120 mbps

    speedof.me shows 10 mbps

    testmy.net shows 10 mbps

    I also tried one of the other SG-1000s we bought for work with the same results for speeds.  My laptop directly behind the work firewall i am able to try the SG-1000s behind i get: speedtest 793, speedof 273, testmy 184

    When I put a public IP on it i got 16 mbps for speedof