Unable to Upgrade Pfsense



  • Hi all;

    I am experiencing an error while trying to upgrade Pfsense 2.3.2 to 2.3.3_1.

    [2.3.2-RELEASE] pfSense-upgrade -d

    Updating repositories metadata…

    Updating pfSense-core repository catalogue...

    pfSense-core repository is up-to-date.

    Updating pfSense repository catalogue...

    pfSense repository is up-to-date.

    All repositories are up-to-date.

    Upgrading pkg...

    Updating pfSense-core repository catalogue...

    pfSense-core repository is up-to-date.

    Updating pfSense repository catalogue...

    pfSense repository is up-to-date.

    All repositories are up-to-date.

    New version of pkg detected; it needs to be installed first.

    Checking integrity... done (0 conflicting)

    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
            pkg: 1.8.7_1 -> 1.9.4_1 [pfSense]

    Number of packages to be upgraded: 1 [1/1] Upgrading pkg from 1.8.7_1
    to 1.9.4_1…

    pkg: sqlite error while executing INSERT OR REPLACE INTO packages(
    origin, name, version, comment, desc, message, arch, maintainer, www,
    prefix, flatsize, automatic, licenselogic, mtree_id, time,
    manifestdigest, dep_formula, vital)VALUES( ?1, ?2, ?3, ?4, ?5, ?6, ?7,
    ?8, ?9, ?10, ?11, ?12, ?13, (SELECT id FROM mtree WHERE content =
    ?14), NOW(), ?15, ?16, ?17 ) in file pkgdb.c:1651: database disk image
    is malformed

    Anyone knows how to resolve this issue without lost the pfsense config?
    I would appreciate any help.
    Thanks in advance.

    Regards.