How to downgrade Netgate SG-1000 from 2.4.0 beta to 2.3.4 stable



  • Hi.  I purchased a Netgate SG-1000 HW product a few weeks ago and it came with 2.4.0 Beta firmware installed on it.  I've had a bunch of problems and I didn't want Beta firmware anyway.  How can I downgrade my installation to 2.3.4 (the latest stable version)?  I don't see any links for downloads on the Netgate web site, and I don't know which image (if any) would be applicable from:  https://www.pfsense.org/download/

    I have the console cable and can get to console mode if required.  I'm hoping to be able to just install 2.3.4 and reconfigure from scratch.

    Any help would be appreciated.

    Mark



  • afaik, the sg-1000 is only supported on the 2.4 platform

    (note: i'm known to be wrong every other day)


  • Netgate

    Only 2.4.0+ supports the ARM processor in the SG-1000.

    2.4 is pretty solid at this point. Maybe post about one of the problems you are having instead?



  • Thanks for the info, I'm submitted other messages on the forum about the issues I'm having.  No luck on those being resolved yet, and I've been unable to get my P2P, Games, and other traffic to be properly classified and prioritized as they should be.

    Mark