Solved: WAN loses IP after a while and cannot reconnect



  • After the Upgrade to 2.3.4 everything seemed fine.
    Then after a few days WAN just went offline and did not reconnect.
    The DHCPclient seems to go into a sort of loop and connect / disconnect.
    This can also be seen on hardware side, the RJ45 ports blink on the modem and on the pfsense box, then goes off and comes on again a few seconds later blinks again for about 15 seconds and goes off for a few.
    A reboot will fix the problem.
    Renewing the IP, unplugging and replugging the eth cable of the wan or disabling and enabling WAN causes this and then only a reboot helps get out of the loop.
    It also seems to happen when pfsense looses the connection to the ISP or modem.
    None of the settings where changes prior to this happening but an upgrade was performed. It could also just be a coincidence.

    Do you have an idea how I can debug / fix this or should I just reinstall?
    I am worried a reinstall and restore will just introduce the same problem again?

    Thanks Martin



  • Many ISP modems will only give out a lease to a single MAC address (first come first served).  Make sure no other devices are connected between the ISP modem and pfSense.
    If pfSense is running on a VM, make sure underlying VM hardware or other VMs can make DHCP requests to the modem.
    I'm guessing if you reset the ISP modem you'll get an IP address once again on pfSense which would indicate there IS some other device that can see the modem.



  • Hi Awebster,
    and thank you for your help and reply!
    pfSense is running on hardware and nothing other than pfSense is connected to the isp modem.
    pfSense was running fine for about a year until I recently updated and the problems started.
    In the meantime I have done a clean install of 2.3.4 and imported all the settings, but that did not solve the problem.
    Thank you for your help and regards,
    Martin



  • I cannot say for curtain but I suspect that during the upgrade the settings of wan somehow got messed up.
    In the WAN settings of the GUI I did not see anything odd. So I reset the pfs, exported the default settings which are ok for me. Compared them with the xml export of the troubled config and just replaced the WAN part of the default export file with my export file which was quite different.
    Now all my wan problems are solved without having to reconfigure everything from scratch.
    Cheers