Issues with Installing 2.3.4 on Watchguard X750e



  • Hello,

    I'm issues with Installing 2.3.4 on Watchguard X750e
    It hangs around IRQ page

    Keep in mind that i made Watchguard fixes already:
    hint.ata.0.mode=PIO4
    hw.msk.msi_disable=1

    any ideas ?



  • Its been a few years since I put together an X-e box but I seem to think if there was a problem reading from the disk/card that it would pause there.


  • Netgate Administrator

    Yup last thing you see when it fails to boot whatever you have in there.

    What are you booting? How did you make those loader fixes if it won't boot?

    What BIOS version are you running? What BIOS settings do you have? You should use the 8.1 BIOS for maximum compatibility.

    Steve



  • I flashed the CF with Pfsense 2.3.4 trying to boot from, no luck so far
    It hangs at the screenshot i submitted

    I do pfsense fixes for Watchguard by mounting the CF to linux machine
    and write the following command to /boot/loader.conf.local:
    hint.ata.0.mode=PIO4
    hw.msk.msi_disable=1

    Bios Award 5.1
    I have another CF and flashed with FreeBios but also can't boot with it to flash the Bios

    IDK what's wrong with it

    Can it be, Watchguard secure Bios ?

    @stephenw10:

    Yup last thing you see when it fails to boot whatever you have in there.

    What are you booting? How did you make those loader fixes if it won't boot?

    What BIOS version are you running? What BIOS settings do you have? You should use the 8.1 BIOS for maximum compatibility.

    Steve


  • Netgate Administrator

    Ok, if you haven't flashed the BIOS to v8.1 then you'll need to set the CHS settings for whatever card you are booting. However since you're seeing some output there via serial I imagine you must have updated the BIOS no?

    What size CF card are you using with 2.3.4 on it? There are some cards that just won't boot whatever you do. The original BIOS is really picky about card geometry.

    Steve



  • Hi,

    Thank you for your reply,

    I'm using ScanDisk Ultra CF 4GB 30MS/s, what would be CHS for it? And where exactly to apply it ?

    @stephenw10:

    Ok, if you haven't flashed the BIOS to v8.1 then you'll need to set the CHS settings for whatever card you are booting. However since you're seeing some output there via serial I imagine you must have updated the BIOS no?

    What size CF card are you using with 2.3.4 on it? There are some cards that just won't boot whatever you do. The original BIOS is really picky about card geometry.

    Steve


  • Netgate Administrator

    You would have the BIOS detect the card initially then change the mode to from auto to CHS and change just the H (heads) value to 2. It will report the wrong CF size but should boot anyway.

    Those are settings to the primary IDE channel in the BIOS setup which you should be able to get into by hitting 'TAB' since you can see some output.

    Really though it would be better to boot from something small enough and flash the 8.1 BIOS which doesn't require that manual work-around.

    Steve



  • Hi,

    I think i finally figure it out
    It's Specs for the CF card in the bios along peripherals settings
    Now, none Pfsense community edition is bootable, the only one work for once was CE for serial edition
    But it hanged as of i have to implement the following fix

    write the following command to /boot/loader.conf.local:
    hint.ata.0.mode=PIO4
    hw.msk.msi_disable=1

    Well, i can't at all, as they made the File System protected

    Any ideas ?

    Thanks

    @stephenw10:

    You would have the BIOS detect the card initially then change the mode to from auto to CHS and change just the H (heads) value to 2. It will report the wrong CF size but should boot anyway.

    Those are settings to the primary IDE channel in the BIOS setup which you should be able to get into by hitting 'TAB' since you can see some output.

    Really though it would be better to boot from something small enough and flash the 8.1 BIOS which doesn't require that manual work-around.

    Steve


  • Netgate Administrator

    You should be using the nanobsd serial image on a CF card there. This one for example: https://atxfiles.pfsense.org/mirror/downloads/pfSense-CE-2.3.4-RELEASE-2g-i386-nanobsd.img.gz

    Steve




Log in to reply