PfSense on CF card. SOLVED



  • Hi Guys.

    I had install several pfsense in CF card already with no issues.

    Now I'm trying to install a new pfSense on the same hardware that I'm using for my gateway, same box etc, the only difference is the CF card that is 2 GB Kingston.

    I try with physdiskwrite on windows and with different images 1.3, 1.2-RC4 etc ( and pfSense-1.2-Embedded.img.gz too) and the box is booting, but the pfshell is never coming up and sometimes is giving me errors of read only file system etc.

    Right now I'm using pfSense-20081105-0745.img.gz for my Acrosser embedded system and is booting and then show this :

    Timecounter "TSC" frequency 1799805544 Hz quality 800
    Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad2: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad2: 1911MB <cf 20071207="" card="" 2gb="">at ata1-master PIO4
    GEOM_LABEL: Label for provider ad2a is ufs/pfSense.
    GEOM_LABEL: Label for provider ad2d is ufs/pfSenseCfg.
    Trying to mount root from ufs:/dev/ufs/pfSense

    ___
    Enter full pathname of shell or RETURN for /bin/sh:
    /etc/rc.initial: cannot create /tmp/last_term_seen: Read-only file system
    [Thu Nov  6 23:26:40 2008] [apc-error] apc_fcntl_create: open(/tmp/.apc.SoUpoK, O_RDWR|O_CREAT, 0666) failed: Read-only file system

    pfSense
         ___
    ___/Enter full pathname of shell or RETURN for /bin/sh:

    I try it several times already and my best boot was when I got to the menu of choosing interfaces, but nothing happen after.

    I'm adding this after like 5 hours trying to solve the problem :

    I create a 512 image and copy that image to my 512 CF card and the problem is exactly the same, and now I'm trying to install to a hard drive with geometric errors, is just not my day with pfsense WFT!!!!!

    Please advice.

    Thanks.</cf></aborted></ready,dsc,error>



  • more updates :

    I'm getting this error now :

    Warning: filesize(): stat failed for /conf/config.xml in /etc/inc/config.inc on line 254

    disabling acpi and dma is doing more stuff, but is always complaining about /cf to run fsck and none of the star scripts run after, even running fsck and rebooting correctly is not doing nothing after.

    PLEASE HELP!!!!!



  • What hardware are you using?
    I had the same problem with my ALIX2c3 and a 1GB Kingston CF. The only way to get it to boot was to disconnect the serial cable from the ALIX, turn it on, wait a few minutes and then connect the serial cable again and configure the interfaces. In my case the booting problem was only when the serial cable was phisically connected to the hardware.
    Now I can configure it using the web interface and it seems to be working fine. My guess is something related to the Kingston CF, but I didn't have the time yet to try another CF brand.



  • I'm using a Acrosser motherboard, Intel Pentium D 1.8, that's work perfecty with linux embbeded and was working yesterday perfectly with pfsense.

    I'm using a bounch of CF cards.

    128, 512, 1g, 2g mainly Kingstom and A-Data.

    I'm using 512 images and standard images of pfsense, two different Car readers, two different programs to dump the image ( dd an phydisk….) and is still not working.

    I think that there is a devil inside of the motherboard.... ;D



  • Update.

    I try what you told me, the serial cable disconnected and now after waiting 3 minutes and connecting back the cable I can see this :

    *** Welcome tob pfSense 2.0-ALPfHA-ALPHA-embeddeed on pfSense ***0
    : link state changed to UP
    bfe1: link state changed to DOWN
    bge0: link state changed to DOWN
    bge1: link state changed to UP

    pfSense console setup


    1. Setting up embedded specific environment…� done.

    ___Enter full pathname of shell or RETURN for /bin/sh:

    *** Welcome to pfSense 2.0-ALPHA-ALPHA-embedded on pfSense ***

    Before I never saw the interfaces comming up and the welcome message.

    What king of bug or configuration can make the console affect the booting process of pfsense ?

    Thanks.



  • Hi guys, is me again…..

    Well finally I got pfSense working in the same appliance but with a hard drive no CF card.

    I install it with the cd and a PCI Video card and no problems.

    And just a minute ago I realize that when I connect the serial port and reboot the machine the pfSense doesn't boot up and stays in single user mode, but if I remove the serial cable and reboot again, everything works fine.

    Why is that ?

    How can enable vga support in the boot options ?

    Thanks.



  • Finally I figure out the problem.

    is the freaking serial usb adapter.

    I'm using this "PL2303 Mac OS X driver v1.2.1r2, Prolific Edition" is a usb-serial adapter and using "screen /dev/usbserial 9600" to connect the serial in the terminal.

    I have another computer with a native serial port and I connected the port directly without the usb-serial adapter and booting with Freesbie and using screen and is working perfectly and now is giving me the option to chose the interfaces and everything.

    Can someone explain me why ?

    Thanks.

    PS : it wasn't the CF card or the image size or the CF reader or the motherboard or the bios or the acpi or the dma, just the #@$$%@#$%@ usb-serial adapter.



  • serial to usb adaptors are a chapter for themself.

    I found that this adaptor:
    https://www.distrelec.ch/ishopWebFront/catalog/product.do/para/node/is/DD-1780/and/highlightNode/is//and/id/is/02/and/series/is/1.html

    has less problems than others.

    (But if you happen to have an application where the developer tries to transmit data with the handshake-lines it's still not fast enough ::) )



  • Great! I'm glad you finally find out the source of the problem.
    I have the same Prolific serial-usb adapter so there's the reason I got the same error :)



  • I'm seeing the same error message, and while I do have an OSX USB Serial adapter, the same error occurs with it disconnected as well, cold booted.  I'm seeing this with the 1.2.1 embedded image, on several USB sticks on two different hardware devices that have always worked easily before.  It seems like some of my USB sticks are working better than the others.  Not sure if this is FreeBSD 7 related or not, I haven't tried a 6-based release yet.



  • This problem may lay a bit deeper, I'm using a Soekris net4801 box, flashed the CF with the new version and still had problems booting with the serial cable connected (a real one; not usb! just 2 sub-d 9pin connectors) between the Soekris and an old XP notebook.

    Initially it looked OK but it seemed the boot stopped before reaching the pfsense part. To get pfsense to run I just disconnected the serial plugged the power and waited a 2 minutes as suggested above. Then plugged in the serial and was just in time to see the last part of the pfsense initialization and the menu coming up, from there changing the LAN address and restoring the configuration went as normal.

    For comparison I also fired up a Soekris net5501, copied the image again to CF and started up. This one boots just fine, with the serial cable connected.



  • @Delex:

    Initially it looked OK but it seemed the boot stopped before reaching the pfsense part.

    Did you get the bootloader on the failed boot?  That is to say, "it's not a hardware problem?"

    I think I saw the FreeBSD 7.1 release notes had something about improved bootloading on USB flash - not sure if that'd be relevant here or not.



  • Yes, I reached the bootloader and was even able to use the menu option to reboot. But that's how far it went no pfsense unless the serial cable was not connected during the first 2/3 minutes, and also only on the 4801 box the 5501 had no problem at all.


Locked