[solved] dhcp6c probably not even starting



  • I seem to have a very basic problem: My ISP changed to IPv6 but pfSense does not acquire any IPv6 address.

    Obviously I've activated IPv6 in Networking and enabled DHCP6 in the corresponding Interface (with various restarts and tries in the DHCP6 Client Configuration where for example debugging is always enabled).

    However I cannot find a sign, that any DHCP6 client would even start. In Status > Interfaces I don't see anything DHCP v6 related (the interface in question has a IPv6 Link Local but I think it also had that before and from my IPv6 knowledge, which is not much, the address looks like a local address). And in the Status > System Logs > DHCP there are only "dhclient" entries for that interface. When I set IPv4 Configuration Type to None for that interface (but keep IPv6 to DHCP6) the last entry here is a "dhclient            exiting.".

    I would look for anything from 'dhcp6c' but I cannot find a single entry with it. Am I just looking in the wrong places or is the client not starting at all? I think I would need at least some log entries to start with…

    Any ideas on this?



  • First, dhclient is used only for IPv4, so its perfectly normal that you see 'dhclient existing' if you've disabled IPv4.
    dhcp6c is what you're looking for in the case of IPv6.
    You should see something like this in the DHCP logs.

    
    Jul 5 17:49:06	dhcp6c	20497	add an address xxxx:xxxx:xxxx:xxxx:20c:29ff:fed0:4475/64 on em1
    Jul 5 17:49:06	dhcp6c	20497	dhcp6c Received REQUEST
    Jul 5 17:49:06	dhcp6c	20497	Sending Request
    Jul 5 17:49:05	dhcp6c	20497	Sending Solicit
    

    You can also enable the "Start DHCP6 client in debug mode", but the normal level of output is sufficient to see if it is working or not.

    If you know what you're looking at, check that you are actually sending and receiving DHCP6 packets.
    Diagnostics -> Packet capture
    Interface: WAN
    Address family: IPv6 only
    Protocol: Any
    Port: Any

    See: https://en.wikipedia.org/wiki/DHCPv6 for details on how it works.



  • Thanks for your answer.

    I was looking for 'dhcp6c', I just wrote a about the behaviour of 'dhclient' to clarify in which log I'm looking for it and that in this log no entries at all get generated when DHCP4 is disabled and DHCP6 still is enabled.

    And it's pretty much the same with packet captures, there are no DHCP6 packets on the wire.

    I have some other pfSense installations running and tried to enable DHCP6 on them (also I don't need it there) and here everything works and looks like I would expect it.
    So I get the feeling further troubleshooting this may be inefficient; I'll probably try to reinstall and if that doesn't help switch the box in a few days.

    Still if someone had a good idea what to do here I'd appreciate it.



  • Before you reinstall pfsense, what settings are you using on the WAN? Do you know what your ISP requires? Your ISP likely did not "change to ipv6". More likely, they supported ipv4 and now they also support ipv6.

    It's quite likely that unless the WAN ipv6 settings are exactly what your ISP requires, the ipv6 gateway won't start.

    I'm referring to the settings on Interface / WAN. Please post a screen capture of this page and also status interfaces.



  • Thanks @bimmerdriver for the input.

    For the record and those which might get in similar situations:

    The problem in this setup meanwhile is resolved and it may very well be that @bimmerdriver were right with the guess as I got it resolved without any further changes of the IPv6 settings. So I knew those from other customers but initially they did not work.
    However after another call with the ISP it turned out that they switched to some sort of IPv6 with "light IPv4" (not sure how you call this stuff were you don't have a real IPv4 anymore but some kind of IPv6 tunnel to a shared IPv4). I definitely didn't want that so I ordered a proper IPv4 asap (which now, who would have guessed, comes with an additional 5€ per month…). With that IPv6 and IPv4 instantly started working. So now I have a proper dual stack and I'm now guessing that I had the correct IPv6 settings but not for this light blabla and only for a proper IPv6/IPv4 dual stack. And it really seems that with improper settings IPv6 isn't coming up at all so that there are also none dhcp6c log entries.



  • i have same problem… I have to set dhcp6 on wan to none... then apply then wait 5 mins then set again.. works like a champ... my isp is comcast