WhatsApp WEB nao gera QRCODE



  • Bom dia,

    Estou utilizando o PfSense 2.3.4 e tenho configurado Squid e SquidGuard. Porém qualquer computador que tenha que passar pelo Proxy, seja tudo liberado ou tudo bloqueado, ele não gera o QR Code, só gera para quem está no Bypass, ou seja, não passa pelo proxy. Meu SquidGuard está assim:

    1 - Tenho IPs cadastrados no bypass (funciona tudo)
    2 - Tenho ACLs bloqueados (ALL > Deny com whitelist liberando sites específicos)
    3 - Tenho ACLs liberados (ALL > Allow com bloqueios de sites pornos etc)
    4 - E por ultimo criei uma regra com tudo ALLOW, mas mesmo assim não gera o QR code. Já criei uma categoria dentro da Shawlist com diversos IPs do whatsapp, diversas URLs e diversas palavras chave para liberar. Aquela lista de CDIRs agora tem que fazer um cadastro no facebook e precisa de e-mail corporativo :\

    Adicionei no SQUID em ACL todas as portas normais e as SSL 1-65535.
    Em Firewall > Rules não tenho nenhum bloqueio de saida, está tudo liberado para tudo (teste)

    Só funciona com os IPs em BYPASS, fora disso não gera a merda do QRCODE… Já fiquei olhando os logs do Proxy junto com o TCPDUMP para ver se havia algum endereço diferente, porém não encontrei nada..

    Se alguem puder ajudar, agradeço e muito, valeu!



  • @nandoiin:

    Só funciona com os IPs em BYPASS

    Sua afirmação é exatamente a sua resposta. Na versão atual do squid, só está gerando o QR code com a rede do whatsapp(destino) no bypass.



  • Instala o firebug e veja onde o teu proxy está bloqueando o QR code.



  • I have same problem, this is bug consolle message on load qrcode:

    _app.f9eac5c174c94d9a8b3c.js:25 WebSocket connection to 'wss://w5.web.whatsapp.com/ws' failed: Error during WebSocket handshake: Unexpected response code: 400
    n @ app.f9eac5c174c94d9a8b3c.js:25

    app.f9eac5c174c94d9a8b3c.js:25 WebSocket connection to 'wss://w6.web.whatsapp.com/ws' failed: Error during WebSocket handshake: Unexpected response code: 400
    n @ app.f9eac5c174c94d9a8b3c.js:25

    WebSocket connection to 'wss://w7.web.whatsapp.com/ws' failed: Error during WebSocket handshake: Unexpected response code: 400
    n @ app.f9eac5c174c94d9a8b3c.js:25_



  • Check your logs and traffic too. Is your proxy transparent?



  • Bom dia,

    Sim, utilizo em modo transparente com certificado para https.

    Como descrevi anteriormente, já 'debuguei' tanto pelos logs do pfsense quanto pelo tcpdump e adicionei todas as conexões geradas, porém não resolveu. Ele mostra varios tcp_miss, mas mesmo adicionando na ACL não muda nada.

    O mais incrível, é que só o proxy habilitado já não funciona, mesmo utilizando todas as politicas do Shalallist como WHITELIST, ter adicionado todos os IPs/URLs do whatsapp + as encontradas pelo log/tcpdump e a politica default como ALLOW ele não passa… Só tirar o IP do proxy ou adicionar no BYPASS funciona hehehe....

    Como disse nosso amigo @marcelloc a versão do squid deve ter algum bug. O caminho que utilizei foi adicionar o IP que irá utilizar o Whatsapp no BYPASS e filtrar no Firewall os sites que ele pode acessar.



  • @danilosv.03:

    Check your logs and traffic too. Is your proxy transparent?

    Yes is transparent but i have tested also with proxy browser setting
    Qrcode works only if i insert "web.whatsapp.com" in Squid ACLs Whitelist



  • @brizzz:

    @danilosv.03:

    Check your logs and traffic too. Is your proxy transparent?

    Yes is transparent but i have tested also with proxy browser setting
    Qrcode works only if i insert "web.whatsapp.com" in Squid ACLs Whitelist

    Have you tried user for range of IP in bypass destination?



  • @nandoiin:

    Bom dia,

    Sim, utilizo em modo transparente com certificado para https.

    Como descrevi anteriormente, já 'debuguei' tanto pelos logs do pfsense quanto pelo tcpdump e adicionei todas as conexões geradas, porém não resolveu. Ele mostra varios tcp_miss, mas mesmo adicionando na ACL não muda nada.

    O mais incrível, é que só o proxy habilitado já não funciona, mesmo utilizando todas as politicas do Shalallist como WHITELIST, ter adicionado todos os IPs/URLs do whatsapp + as encontradas pelo log/tcpdump e a politica default como ALLOW ele não passa… Só tirar o IP do proxy ou adicionar no BYPASS funciona hehehe....

    Como disse nosso amigo @marcelloc a versão do squid deve ter algum bug. O caminho que utilizei foi adicionar o IP que irá utilizar o Whatsapp no BYPASS e filtrar no Firewall os sites que ele pode acessar.

    Instale o firebug no navegador e veja em qual regra está caindo o bloqueio.



  • Passei por esse problema e descobri que no Firefox ao ir no menu avançado - preferência/avançado/rede/configurar conexão… marcar a caixa proxy DNS socket v5. Aí abre na hora!

    Logicamente todos as liberações do squidguard e firewall já estavam ok, só faltava isso mesmo! Espero que ajude a você também!



  • Amigos, só resolvi criando um Alias com os seguintes hosts e depois adicionando em bypass:

    w1.web.whatsapp.com
    w2.web.whatsapp.com
    w3.web.whatsapp.com
    .
    .
    .
    w10.web.whatsapp.com

    Não sei se é a forma mais certa, sou novato, mas funcionou.