AutoConfigBackup issues..



  • I have 3 systems at this time running PFsense software, I have an intel box running 2.3.4, another intel box running 2.4 beta, and also picked up an SG-1000 that is running 2.4 as well.

    I have AutoConfigBackup configured on all three servers, and on both of the 2.4 boxes the backups are working perfectly.  Now the 2.3.4 is a totally different story, or well it's sort of working.  When it does a backup, the backup then shows on the restore listing, so it appears it's backing up, but every time it does an update, I get a red alarm bell notification saying that it didn't work.

    I have re-configured the application, I have uninstalled and re-installed the AutoConfigBackup module and set it up again, but always the same result.

    Here is the error message it gives me:

    
    AutoConfigBackup - An error occurred while uploading your pfSense configuration to portal.pfsense.org ()	@ 2017-07-06 15:09:05
    
    

    Has anyone run into this, and if so any ideas on how to resolve it??


  • Rebel Alliance Developer Netgate

    How large is the configuration file on that system? If you look on Diagnostics > Backup & Restore, on the Config History tab you can see the size there. Or take a backup and check how large it is.



  • Thanks for the reply Jim, and looking at the config backup screen, it's showing 115KiB for the size, granted in the history I see entries that go back to 111KiB that still failed.

    Not sure if that is a large config, but I do have a bunch of IPsec VPN's to various clients, so guessing that could increase the size some, granted it doesn't seem that outlandish of a config for PFsense.

    If there is a size limit on the auto backup, what is it??


  • Rebel Alliance Developer Netgate

    Nowhere near that :-)

    Last time I saw a similar issue it was a huge config, several MB, and it still had rrd data backed up inside config.xml.

    If it works from other systems it can't be your account, though. And the ACB package code is identical on 2.4 and 2.3.4, so that may not be the difference either.

    Is there anything different about the WAN connectivity at this location? Maybe it has (or thinks it has) IPv6 when the others do not, or vice versa?
    Any different packages? Anything different between it and the Internet in general?



  • Well let's see, what is different about this machine/location.  Stuff I can think of off the top of my head per your comments.

    This location does have IPv6 and actively uses it, so I have rules and all in place to control IPv6 as well as IPv4.

    This server has a two port Intel X520 10 GigE board installed and is in use, so additional interfaces over the 4x GE ports that are on the actual motherboard.

    Finally, this server has a GPS timing source connected, so is maintaining an accurate stratum timing source for other servers on the network to grab time from.

    Outside that, as mentioned earlier, it has a bunch of VPN's configured, with a pile of Phase 2 entries under IPsec.

    If there is any type of config info I can provide that would help, or any type of logging from the autobackup, let me know..


  • Rebel Alliance Developer Netgate

    Only logging would be to the main system log.

    You might try Diagnostics > Test Port and have it connect using your WAN to portal.pfsense.org on port 443, try both IPv4 and IPv6. See if it fails both or just IPv6.



  • Thanks for the reply Jim.

    I ran the test port on both IPv4 and IPv6, using both portal.pfsense.org, and also using the actual IP address, and every case passed with flying colors.  So the connectivity back to portal is not the issue, not that I actually expected it to be with the fiber internet here at this location.

    I can do a local backup just fine, so I am at a loss as to why the backup to portal fails, is there any logging you have access to on Portal?  As I can provide you with the IP address if needed to take a look..


  • Rebel Alliance Developer Netgate

    If you are still having issues, login to the portal and open a support ticket and someone can take a deeper look with you. Even though Gold does not include support access, if you have a problem with AutoConfigBackup they can help you get it working.


Log in to reply