[Soekris net5501] Boot problem



  • Hello all,

    I ve just installed PfSense on a CF like i had installed M0n0wall (who works) :

    zcat pfSense-1.2-Embedded.img.gz | dd of=/dev/sdc bs=16k

    When I try to boot, i ve this message :

    comBIOS ver. 1.33  20070103  Copyright (C) 2000-2007 Soekris Engineering.

    net5501

    0512 Mbyte Memory                        CPU Geode LX 500 Mhz

    Pri Mas  SanDisk SDCFB-32                LBA 490-4-32  31 Mbyte

    Slot  Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2  Int             
    –-----------------------------------------------------------------           
    0:01:2 1022 2082 10100000 0006 0220 08 00 00 A0000000 00000000 10             
    0:06:0 1106 3053 02000096 0117 0210 08 40 00 0000E101 A0004000 11             
    0:07:0 1106 3053 02000096 0117 0210 08 40 00 0000E201 A0004100 05             
    0:08:0 1106 3053 02000096 0117 0210 08 40 00 0000E301 A0004200 09             
    0:09:0 1106 3053 02000096 0117 0210 08 40 00 0000E401 A0004300 12             
    0:14:0 104C AC23 06040002 0107 0210 08 40 01 00000000 00000000                 
    0:20:0 1022 2090 06010003 0009 02A0 08 40 80 00006001 00006101                 
    0:20:2 1022 209A 01018001 0005 02A0 08 00 00 00000000 00000000                 
    0:21:0 1022 2094 0C031002 0006 0230 08 00 80 A0005000 00000000 15             
    0:21:1 1022 2095 0C032002 0006 0230 08 00 00 A0006000 00000000 15             
    1:00:0 100B 0020 02000000 0107 0290 00 40 00 0000D001 A4000000 10             
    1:01:0 100B 0020 02000000 0107 0290 00 40 00 0000D101 A4001000 07             
    1:02:0 100B 0020 02000000 0107 0290 00 40 00 0000D201 A4002000 10             
    1:03:0 100B 0020 02000000 0107 0290 00 40 00 0000D301 A4003000 07

    1 Seconds to automatic boot.  Press Ctrl-P for entering Monitor.             
    No /boot/loader

    FreeBSD/i386 boot                                                             
    Default: 0:ad(0,a)/boot/kernel/kernel                                         
    boot:                                                                         
    No /boot/kernel/kernel

    FreeBSD/i386 boot                                                             
    Default: 0:ad(0,a)/boot/kernel/kernel                                         
    boot:

    I ve chek to the BootTroubleShooting guide, but nothing to do.

    Is anyone can help me ?





  • I try the RC2 the RC4 … nothing to do. When i try with an RC* the Soekris does not see the OS, it boot on the bios. Sorry but I didn't see what to do :/

    I had try all that :

    pfSense-1.2-Embedded.img.gz
    pfSense-1.2-RC2-Embedded.img.gz
    pfSense-1.2-RC4-Embedded.img.gz
    pfSense-Embedded-Update-1.2.1-RC2-20081109-1312.tgz
    pfSense-Full-Update-1.2.1-RC2-20081109-1312.tgz

    ??? ??? ???



  • In reality all the .tgz that I "zcat and dd" won't be copied in my CF.
    When I try with a .img.gz the files are copied into the CF. I don't know why.
    How can i execute "zcat file.tgz | dd of=/dev/sdc bs=16k" correctly ?

    So when i do

    pfSense-1.2-RC4-Embedded.img.gz | dd of=/dev/sdc bs=16k

    (or RC2) the box boot but the problem stay the same.

    FreeBSD/i386 boot                                                             
    Default: 0:ad(0,a)/boot/kernel/kernel                                         
    boot: No /boot/kernel/kernel

    Please help me I doesn't find anything on the forum :/ Thanks



  • @bouyafa:

    Pri Mas  SanDisk SDCFB-32                LBA 490-4-32  31 Mbyte

    Um, Is that a 32 MB flash card?? You need at least a 128 MB card for 1.2.



  • Yes in effect, I had see that Sunday evening :p  ::) ::) ::)



  • And now all works good :]

    Hum Is there a bug in the menu ? I can't acces to  Diagnostic / Firmware / General Setup / … It appears when I drag the mouse on the 'System' button, but disapear when I try to touch it :p And Appears a 'ARP Table / Backup / Command / ... / ... ' menu. I'm using Firefox 3, I will try with Konqueror.



  • Yes it's a bug. With Konqueror I have a new menu what i hadn't with firefox3, the menu 'Diagnostic' :p
    So with Knoqueror all works.  :-\


Log in to reply