Unbound regularly restarted by rc.newwanipv6 even though not change in IP



  • Hi,

    I am seeing an annoying issue on my current setup. Yesterday i could log it about every 18 minutes for a certain period.
    newwanipv6 is being called and is issuing a restart on all relevant packages. This includes unbound. Due to the time it takes to restart unbound, (approx 10-15 seconds) clients can no longer browse the internet as they do not a reply on DNS requests.
    However there is no change in IP which would even require for such a restart

    Setup:

    Ipv4 - DHCP, private IP is being issued by provider (provider itself uses CGNAT on outgoing Ipv4)
    IPV6 - DHCPv6, prefix hint /56 enabled, do not wait for RA

    Both IPs are being assigned and do not change

    In the meantime i have tried to
    -disable gateway monitoring
    -different settings for DHCPv6
    -disable host registration in DNS resolver
    -tried uncommenting unbound and restart packages in newwanip (i did it wrong as unbound is still being restarted)

    • checked for the entries in /var/db for the ip which are actually set correctly to the current values

    What else should I look at?



  • Alright, found this ticket and believe my issue is related…
    https://redmine.pfsense.org/issues/7145


Log in to reply