Unable to update SG-2220 to 2.3.4-p1



  • So I tried to update my trusty SG-2220 from the web interface, only for it to say it was up to date. I thought that was odd, since my production boxes at other sites showed the upgrade as available and successfully did their thing on the first try. I tried SSHing in to the machine, and upon hitting option 13, got the following:

    *** Welcome to pfSense 2.3.4-RELEASE (amd64 full-install) on bulwark ***

    WAN (wan)      -> igb0      -> v4/DHCP4: x.x.x.x/24
    LAN (lan)      -> igb1      -> v4: 192.168.1.1/24

    1. Logout (SSH only)                  9) pfTop
    2. Assign Interfaces                10) Filter Logs
    3. Set interface(s) IP address      11) Restart webConfigurator
    4. Reset webConfigurator password    12) PHP shell + pfSense tools
    5. Reset to factory defaults        13) Update from console
    6. Reboot system                    14) Disable Secure Shell (sshd)
    7. Halt system                      15) Restore recent configuration
    8. Ping host                        16) Restart PHP-FPM
    9. Shell

    Enter an option: 13

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pkg: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    Fetching meta.txz: . done
    pkg: No signature found
    repository pfSense-core has no meta file, using default settings
    Fetching packagesite.txz: . done
    pkg: No signature found
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    Error updating repositories!

    Sure enough, /var/db/pkg/repo-pfSense-core.sqlite doesn't exist - not sure how that went missing (I don't touch the filesystem directly ever), but now I can't apply the update, it seems. I don't want to do anything too drastic since I'm not at this site at the moment, but what are the next steps I can take to get this up to date safely? Thanks for any help!



  • Hi,

    I got the very same errors with my pfSense/Netgate SG-4860 when trying upgrade from 2.3.4 to 2.3.4-p1.

    Some non-local problems with pfSense repositories/signatures maybe?

    Thanks for your help.


  • Rebel Alliance Developer Netgate

    There was a temporary issue shortly after the release which affected some users and prevented them from updating parts of the package repository. It should be all cleared up now. Let us know if you still have problems.



  • Sure enough, it's working now. Thanks!