Multi-WAN & FTP Server (again!)



  • Hi all,
    I previously had this working with a dual-wan setup.  Unfortunately, I had to add in a third WAN connection, but since this ISP requires PPoE, I actually had to make the new connection WAN1, and then make what was WAN1 be WAN2, and what was WAN2 be WAN3.  I know this is an often reported problem, and I've been through all the guides and forum posts on this one, but haven't been able to get this going with any of them.

    I have all of the 'FTP Helper' options enabled (not checked to disable), but have tried disabling them with no result.

    I have the following NAT rules, and the associated automatically created WAN2/WAN3 rulesets:
    WAN2 TCP 21 192.168.10.100 21
    WAN3 TCP 21 192.168.10.100 21

    I've also forced my FTP server to use ports 5500-5700 for PASV connections, and have the following rule:

    WAN2:
    TCP * * * 5500-5700 WAN2Gateway

    WAN3:
    TCP * * * 5500-5700 WAN3Gateway

    On the LAN side,  I have the following rules above all other rules:
    TCP LANnet * 127.0.0.1 8000-8049 WAN2Gateway
    TCP LANnet * 127.0.0.1 8000-8049 WAN3Gateway

    Is there something obvious that I'm missing?  Any help would be greatly appreciated!



  • On your LAN firewall rules, try removing one of the rules you have quoted, on the rule thats left, try setting the gateway to "Default".

    see if that makes a difference.



  • It doesn't seem to make any difference unfortunately.



  • Also, the only way that I can get any response on the client side is to DISABLE the FTP Helper App on the WAN side.  With the FTP Helper disabled, the connecting client can connect ok, but will not get past the directory listing stage before timing out.

    with the ftp helper enabled, the client can't even connect.



  • the second rule from the lan has no sense

    TCP LANnet * 127.0.0.1 8000-8049 WAN2Gateway
    TCP LANnet * 127.0.0.1 8000-8049 WAN3Gateway

    the order to process the rules is from top to bottom
    and i understand well u are tring to disable ftp.
    If i`m right jut put on every NIC a rule to block FTP


Log in to reply