APU2C4 + traffic shaper = kernel panic



  • I'm trying to configure trafic shaper on PC Engines APU2C4.

    As soon as I configure trafic shaper (manualy or the wizard) with CBQ, the pfsense is stuck just after config validation…

    I'm using pf2.3.4_1.

    Any idea?



  • I can tell you that this occurs with CBQ only and not HFSC…



  • I saw the ticket about this, which got labelled "rejected": https://redmine.pfsense.org/issues/7713

    The last comment on that ticket is

    It is highly unlikely that we will make special considerations for just that hardware platform, especially when it's a hardware platform that we do not officially support.

    I just wanted to comment that I'm a bit uncomfortable with how the pfSense devs handled that ticket.  pfSense allegedly crashes on a certain system and they don't want to look into it.  That system just happens to be the very popular APU2, which used to be officially sold on their store, but for some reason (conflict?), is no longer available there.  My first thought was that they are intentionally letting the APU2 owners suffer to punish them for not buying a system from their official store but instead buying from their apparent enemy, PC-Engines.  I manage several APU2's because they used to be officially supported, and I want to trust that they will continue to be given the same love and attention that any other popular 3rd party system is given.



  • @Jeremy_99:

    I just wanted to comment that I'm a bit uncomfortable with how the pfSense devs handled that ticket.

    IIRC, they only sold the APU1 before moving to ADI.
    I took it as a reply to the suggestion that the software remove the option for CBQ if it detects the platform is APU2.
    I'd like to think that the ticket was closed due to it not being narrowed down enough in the forum. I may be a configuration issue, or not hardware specific. I do agree that the ticket closing could have been handled better. It comes off kind of ' not official hardware? no souport for you' Probably not what was intended.



  • @Jeremy_99:

    I saw the ticket about this, which got labelled "rejected": https://redmine.pfsense.org/issues/7713

    The last comment on that ticket is

    It is highly unlikely that we will make special considerations for just that hardware platform, especially when it's a hardware platform that we do not officially support.

    I just wanted to comment that I'm a bit uncomfortable with how the pfSense devs handled that ticket.  pfSense allegedly crashes on a certain system and they don't want to look into it.  That system just happens to be the very popular APU2, which used to be officially sold on their store, but for some reason (conflict?), is no longer available there.  My first thought was that they are intentionally letting the APU2 owners suffer to punish them for not buying a system from their official store but instead buying from their apparent enemy, PC-Engines.  I manage several APU2's because they used to be officially supported, and I want to trust that they will continue to be given the same love and attention that any other popular 3rd party system is given.

    Thanks for you support, PC Engines support provided exactly the same answer as your. They don't made any effort for hardware "external"…



  • @dotdash:

    @Jeremy_99:

    I just wanted to comment that I'm a bit uncomfortable with how the pfSense devs handled that ticket.

    IIRC, they only sold the APU1 before moving to ADI.
    I took it as a reply to the suggestion that the software remove the option for CBQ if it detects the platform is APU2.
    I'd like to think that the ticket was closed due to it not being narrowed down enough in the forum. I may be a configuration issue, or not hardware specific. I do agree that the ticket closing could have been handled better. It comes off kind of ' not official hardware? no souport for you' Probably not what was intended.

    Sorry but I don't agree with your position because pfsense team didn't try to understand what happen on APU2.

    This easy and there isn't any config issue :

    • You make a fresh install of pfsense of APU2
    • You had a new interface with vlan (for voice in my case)
    • You activate traffic shaper witch CBQ (wizard or manually)

    -> as soon as you validate queue or end of wizard apu2 is stuck…

    I'm sorry but something like this you must take some time to see what's happen...and not close directly the ticket.

    During that time I will be using HFSC et starting to use OPNsense which is fully supporting APU2... that's a pity after 5 years with pfsense and so much appliance installed on customer sites...



  • Just a suggestion: Your ticket was about 2.3.4, but pfSense 2.4 is coming out soon and it has lots of improvements.  You should try the latest 2.4 alpha now and see if that fixes the issue.  I've been running 2.4 on a virtual machine for a few months now and it has been perfect.



  • docteur trigger the crash again and please post the backtrace here, I will then look to see if the issue is raised as a FreeBSD PR.



  • @chrcoluk:

    docteur trigger the crash again and please post the backtrace here, I will then look to see if the issue is raised as a FreeBSD PR.

    Thanks. I will do that asap.