IPv6 Issues



  • I've just started having issues with IPv6 where I have not before.  I am uncertain what what has changed.  I have tried everything that I can think of but I am unable to get a DHCP6 lease on my WAN.  Attached are the debug logs, they seem to get stuck on the following two steps:

    Jul 26 11:13:32 dhcp6c 27415 reset a timer on em0, state=SOLICIT, timeo=357, retrans=130776
    Jul 26 11:13:32 dhcp6c 27415 send solicit to ff02::1:2%em0

    Any ideas on things I should check would be most appreciated.

    Ryan




  • No reply from the ISP to your solicits is the issue. Do you have dhcp before RA enabled, if so try with it turned off, or turn it on if its currently off.

    Look for a log entry like this in your system log:

    Jul 28 13:45:39 rtsold Received RA specifying route fe80::20d:b9ff:fe44:7271 for interface wan(re0)

    You need to see that entry somewhere.



  • I don not see a "DHCP before RA" option.  Is this the same as "Do not wait for a RA"?  I had this on, and have just turned it off, so far with no luck.

    I seem to recall when I setup IPv6 that there was a port or something that I needed to unblock on the WAN firewall to allow IPv6 responses to be received by the firewall.  I've gone through my configuration and can't find that.  I've also gone through all of the IPv6 Implementation manuals and can't find anything link that.  Was I imagining that or is there something that needs to be unblocked to receive the responses?



  • You should not need to open any ports for ipv6 to work.

    If I understand your original post, you are saying it used to work, then it stopped working. Did you update pfsense or make any changes to the settings of pfsense around the time it stopped working? If not, possibly your isp changed something.

    It might help if you posted your interface wan settings.



  • I finally gave up and contacted Time Warner.  They had disabled IPv6 for everyone and were enabling it at the customer's request only going forward.  It sounds like it was causing too many headaches for them.  They enabled it again for me and it works now…. It would have been nice to know that before spending 10 hours troubleshooting.



  • They had disabled IPv6 for everyone and were enabling it at the customer's request only going forward.

    That's really stupid!!!!

    The world is moving to IPv6 and this is just a step backward.



  • @vc6SfV8:

    I finally gave up and contacted Time Warner.  They had disabled IPv6 for everyone and were enabling it at the customer's request only going forward.  It sounds like it was causing too many headaches for them.  They enabled it again for me and it works now…. It would have been nice to know that before spending 10 hours troubleshooting.

    Good for you, calling them! Sends a good message.


Log in to reply