Pfsense 1.2.1 doesn't boot!



  • Hi,
    I've just installed the 1.2.1 version but, after the installation, pfsense can't boot.
    I see the menu "Welcome to FreeBSD" but when the os tries to start it hangs on with the "|" prompt.
    Where is the problem? How can I solve it?

    Thanks to all



  • More information.
    Embedded or fullinstall? Hardware?



  • -pfsense Full installation
    -Mainboard Asrock wolfdale 1333 gigalan realtek onboard
    -2 add-on zyxel network interfaces (chipset rtl8169sc)
    -hdd 80Gb sata



  • Does this motherboard have a fairly recent Intel chipset?
    Is the boot device on a "legacy" controller (can be either IDE or SATA but RAID may not work well.) There may be a BIOS setting for this; there certainly seems to be in the ASUS and Gigagbyte motherboards I looked at a while ago. I suspect from some other reports I have seen that the FreeBSD boot code doesn't cope too well if the boot disk is on a controller at "non standard" addresses.



  • chipset is Intel 945Gc A2…I've already selected in the bios settings "legacy"...but nothing....sometimes it hangs on just before the free-bsd menu!
    I have to buy another mainboard? Which kind of mainboard / chipset isbetter fo pfsense?

    thank again



  • Could you boot again from the install medium (CD? SATA? IDE?) and configure it enough to be able to access the system through the web interface or ssh and then capture the startup output (displayed by dmesg command) of that boot and post it here?

    Does the motherboard support boot from USB memory stick? If so, you could try installing to a USB memory stick (1GB would be big enough, larger would be OK) and see if you can reliably boot from that. I appreciate you may not want to do that permanently but it could be useful to help understand what is going on.  I've not had any trouble booting FreeBSD off USB CDs. USB hard drives or USB memory sticks but I've seen reports that some people have had troubles booting from USB devices.



  • @Vincenzo:

    chipset is Intel 945Gc A2…I've already selected in the bios settings "legacy"...but nothing....sometimes it hangs on just before the free-bsd menu!
    I have to buy another mainboard? Which kind of mainboard / chipset isbetter fo pfsense?

    thank again

    I don't see know of any reason why pfSense wouldn't work with that motherboard.


Log in to reply