IPSEC between Fortigate 1500D and Pfsense 2.3.4_1



  • Hi everybody and thanks in advance for your help, I'm trying to establish an IPSEC connection between PfSense 2.3.4_1 and Fortigate-1500D with the following configuration:

    IKE Parameters (Phase 1)
    Authentication method Shared Secret
    Key Exchange encryption AES256
    Data Integrity SHA1
    Diffie-Hellman group (phase 1) Group 5
    Timer IKE phase 1 86400 Sec
    Use aggressive mode No
    FQDN (Cisco) No

    IPSEC parameters (Phase 2)
    UDP encapsulation No
    IPSEC AES256
    Data Integrity SHA1
    Perferct Forward Secrecy No
    Diffie-Hellman group N/A
    Timer IKE phase 2 28800 Sec

    The tunnel is not coming up, is failing on Phase1. This is what the log says:

    Jul 30 22:22:02 charon 12[CFG] <5105> received proposals: IKE:AES_CBC_256/HMAC_SHA1_96/PRF_HMAC_SHA1/MODP_1536

    Jul 30 22:22:02 charon 12[CFG] <5105> configured proposals: IKE:AES_CBC_128/HMAC_SHA2_256_128/PRF_HMAC_SHA2_256/MODP_3072,
    IKE:AES_CBC_128/AES_CBC_192/AES_CBC_256/CAMELLIA_CBC_128/CAMELLIA_CBC_192/
    CAMELLIA_CBC_256/3DES_CBC/HMAC_SHA2_256_128/HMAC_SHA2_384_192/
    HMAC_SHA2_512_256/HMAC_MD5_96/HMAC_SHA1_96/AES_XCBC_96/AES_CMAC_96/
    PRF_HMAC_SHA2_256/PRF_HMAC_SHA2_384/PRF_HMAC_SHA2_512/PRF_AES128_XCBC/
    PRF_AES128_CMAC/PRF_HMAC_MD5/PRF_HMAC_SHA1/ECP_256/ECP_384/ECP_521/
    ECP_256_BP/ECP_384_BP/ECP_512_BP/MODP_3072/MODP_4096/MODP_8192/
    MODP_2048/MODP_2048_256/MODP_1024, IKE:AES_GCM_16_128/AES_GCM_16_192/AES_GCM_16_256/AES_GCM_12_128/
    AES_GCM_12_192/AES_GCM_12_256/AES_GCM_8_128/AES_GCM_8_192/AES_GCM_8_256/
    PRF_HMAC_SHA2_256/PRF_HMAC_SHA2_384/PRF_HMAC_SHA2_512/PRF_AES128_XCBC/
    PRF_AES128_CMAC/PRF_HMAC_MD5/PRF_HMAC_SHA1/ECP_256/ECP_384/ECP_521/
    ECP_256_BP/ECP_384_BP/ECP_512_BP/MODP_3072/MODP_4096/MODP_8192/MODP_2048/
    MODP_2048_256/MODP_1024

    Jul 30 22:22:02 charon 12[IKE] <5105> no proposal found
    Jul 30 22:22:02 charon 12[ENC] <5105> generating INFORMATIONAL_V1 request 2041983354 [ N(NO_PROP) ]

    As far as I can see my Pfsense box has configured DH Group 5 (1536 bits) but in the log I can't see that my Pfsense has configured that option MODP_1536. I've changed the setting to other DH Groups without luck. How can I make my Pfsense box to offer MODP_1536 proposal in order to make a succesful connection?

    Thanks again, Javier.