System util 50% CPU non stop



  • How can I tell what is causing the router CPU to stay at 50% non stop all the time?

    When I run top -aSH I get these results:

    last pid: 50746;  load averages:  1.09,  1.05,  1.01  up 20+06:21:25    16:35:10
    126 processes: 4 running, 96 sleeping, 26 waiting
    
    Mem: 9392K Active, 99M Inact, 200M Wired, 34M Buf, 3592M Free
    Swap: 8192M Total, 8192M Free
    
      PID USERNAME PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
        9 root     -16 ki-1     0K    16K CPU1    1 486.3H 100.00% [idlepoll]
       11 root     155 ki31     0K    32K RUN     0 475.2H 100.00% [idle{idle: cpu0}]
    75556 root      33    0   272M 39856K piperd  0   0:04   4.69% php-fpm: pool nginx (php-fpm)
       12 root     -60    -     0K   416K WAIT    0 158:36   0.00% [intr{swi4: clock}]
       11 root     155 ki31     0K    32K RUN     1  81:13   0.00% [idle{idle: cpu1}]
       15 root     -16    -     0K    16K -       0  77:23   0.00% [rand_harvestq]
    38685 root      52   20 17000K  2424K wait    0   9:57   0.00% /bin/sh /var/db/rrd/updaterrd.sh
        5 root     -16    -     0K    16K pftm    0   7:33   0.00% [pf purge]
       16 root     -72    -     0K    80K -       0   3:03   0.00% [usb{usbus0}]
    16720 root      20    0 19108K  2252K nanslp  0   2:53   0.00% [dpinger{dpinger}]
    16134 root      20    0 19108K  2248K nanslp  0   2:32   0.00% [dpinger{dpinger}]
    24897 root      20    0 30152K 17980K select  0   1:57   0.00% /usr/local/sbin/ntpd -g -c /var/etc/ntpd.conf -p /var/run/ntpd.pid{ntpd}
       12 root     -88    -     0K   416K WAIT    1   1:41   0.00% [intr{irq22: ehci0}]
    13938 root      20    0 16676K  2216K bpf     0   1:39   0.00% /usr/local/sbin/filterlog -i pflog0 -p /var/run/filterlog.pid
    24309 root      20    0 39144K  6540K kqread  0   1:27   0.00% nginx: worker process (nginx)
    23122 root      20    0 39144K  6540K kqread  0   1:26   0.00% nginx: worker process (nginx)
    22837 root      20    0 39144K  7124K kqread  0   1:26   0.00% nginx: worker process (nginx)
    24318 root      20    0 39144K  6540K kqread  0   1:26   0.00% nginx: worker process (nginx)
    

    However the dashboard shows CPU at 50% all the time and status monitoring shows it as well.

    I have 3 packages installed, autoconfigbackup, aws-wizard, and ipsec-profile-wizard



  • Looks like you enabled polling. Instead of an event based system that reacts when new packets come in, it spins at 100% CPU checking to see if any new packets came in.



  • @Harvy66:

    Looks like you enabled polling. Instead of an event based system that reacts when new packets come in, it spins at 100% CPU checking to see if any new packets came in.

    You rock :) Thanks.