Locked out of pfSense by wrong port config, how do I reset from Serial Console?



  • As the topic says, I've managed to misconfigure the WAN/LAN ports on a pfSense box that only has 2 ethernet ports and a serial port.

    I am able to connect via the serial cable, but at the FIRST menu, autoconfig didn't work for resetting the ports (em0, em1, em2, em3 etc.) so I guessed, apparently incorrectly.

    Now I don't get that same option in the serial console, nor do I see it anywhere in the serial console menu.

    pfSense now loads a Menu(6 options, pasting in here caused an error)  in the serial console, but I can't find any option to reset the ports?

    I am guessing the ports can be reset from here, but I've tried going back to the old kernel, no luck, Loader Prompt doesn't seem to give a clear indication of what to enter for the port changes, same for Boot Options.

    Clearly I messed up royally somewhere, help would be appreciated.

    As it is now, neither of the ethernet ports seems to function at all.



  • You should be able to access the pfsense pc by using a normal keyboard and mouse, connected directly to the pc.
    There you have an option to reset and change web config adapter settings etc.



  • @kdes:

    You should be able to access the pfsense pc by using a normal keyboard and mouse, connected directly to the pc.
    …..

    =>
    @ProblemsGalore:

    ….. a pfSense box that only has 2 ethernet ports and a serial port.

    I you ave serial access, see the manual of the device to gain access to the drive (file system).
    Edit /conf/config.xml directly - or, better : replace it with a recent backup.



  • can you do a factory reset?
    that's what I would do as a last resort.
    or like poster above wrote
    edit
    vi /cf/conf/config.xml
    or
    pkg install nano
    nano -w /cf/conf/config.xml

    because over serial console vi didn't work the way it should.



  • Thanks for the replies, all.

    No luck so far, for whatever reason (by design??) when I let pfSense load fully, the console doesn't seem to allow any keyboard entry.  It displays the loading information, that's all.

    If I stop the loading procedure (hit Escape at the start) the bare bones boot menu doesn't have vi or anything else seemingly to edit any files, and definitely no pkg. No internet connection now either, as both Ethernet ports are locked out. Part of the problem seems to be that there are two OTHER ethernet ports, physically, on the outside, with apparently some form of miswired connection internally.  They were hidden under tape on one side.  They don't work either, and seem to be (the taped 2) set up as just a pass through connection, nothing going into the pfsense box itself.

    Yes, this is a used device I bought off of Ebay. :(

    I'm not having much luck at all with the console, so I tried Factory Reset. That just causes the box to reboot repeatedly, and now even changing between kernels does nothing. Definitely a last resort. :|

    I'm downloading USB images of pfSense now to start over, there is a USB port here also.

    I've got multiple old config files saved, but no way to upload them in this state? I'll just try to format and start over.

    Part of the issue was, I have two pfSense boxes, with different hardware of course, but 99.9% the same config(same users, etc.), and I accidentally put a new config for the OTHER box on this one. Instant Port mismatch, which does pop up when you try to load the new config, but honestly I was confused by the drop down menu for the WAN/LAN options… if those aren't valid ports on THIS box, how can they even show up as an option? Live and learn I guess. Once I get the ports straightened out in the future(4 ethernet total, minus 2 physically disabled on one side) I'll just physically write them down on the side of this box, to avoid this nonsense in another 2 years.  And have more clearly labeled back up configs....    Multiple mistakes.



  • Are you setting the serial on the right speed?
    If you get the boot manager, the it is likely you are setting it too slow.

    115200/8/N/1



  • Oh, whoops, the speed was set incorrectly(9600).  Thanks, heper.  I'll try 115200 when I get some free time.

    Thanks!


Log in to reply