Multicast IPTV, igmpproxy issues, BT TV, BT Sport 4K



  • Hi,

    I have just clean installed 2.3.4 and updated it from the web GUI.

    I have followed this guide by james_h to set up IPTV with BT: https://forum.pfsense.org/index.php?topic=74126.0
    I previously used this guide with 2.4.0 beta and it did work ok - kind of, streams quit after 4-5mins.
    (igmpproxy is known to be bust as per: https://redmine.pfsense.org/issues/6099#note-112)

    Any ideas/help please?
    Has anyone got BT TV and 4K Sport working with 2.3.4?

    Thanks, spazicus



  • These instructions by james_h DO work (Reply #3): https://forum.pfsense.org/index.php?topic=74126.0

    Just this ONE EXTRA STEP is needed though:

    "For my BT UltraHD youview box  i also needed another pass rule on the IPTV Wan interface we create.
    This should allow IPV4 IGMP, from a source of any, to destination of network 224.0.0.0/4 (with Advanced Options -> "Allow packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic" ticked) otherwise the picture would drop out after 4 minutes."

    For 2.4.0-BETA, igmpproxy IS working correctly - no updates/fixes are needed.

    Working 100% for UK BT TV, BT Sport 4K (IPTV over BT Infinity FTTC/P) in ver. 2.4.0-BETA (Version 2.4.0.b.20170807.0351), 3x Intel NIC's used.



  • Full instructions for PfSense 2.4.0

    You need to create a new interface on your WAN Side as the multicast is delivered to the actual interface and not the PPPOE interface. You can just give this any IP address, we used 10.20.30.1

    I have a separate LAN interface (I have a 4 port Intel NIC and use 3 of the ports) to stop the multicast from flooding my LAN. I put a block all rule between my multicast IPTV_LAN and normal LAN. In the firewall ALLOW rule for your IPTV_LAN, you need to make sure under "Advanced Options" that "Allow packets with IP options to pass" is ticked.

    You will also need to configure your WAN Firewall rules to allow IGMP and UDP Packets. In the IGMP firewall rule for your IPTV_WAN, you need to make sure under "Advanced Options" that "Allow packets with IP options to pass" is ticked.

    The IGMP Proxy Config requires upstream and downstream configuring:
    Downstream will just be your multicast IPTV_LAN network, 192.168.4.0/24
    Upstream we have the following which works, 224.0.0.0/4 and 109.159.247.0/24

    Manually set the IP of your BT YouView box to 192.168.4.2, set the gateway to 192.168.4.1, the BT DNS servers (you don't actually need to use them) are 81.139.57.100 and 81.139.56.100

    1.

    2.

    3.

    4.

    4b.

    5.

    6.

    6b.

    :)



  • Great guide. Thanks  ;D



  • Thanks a lot! This guide helped me to make multicast between different vlan for cloning with fog



  • I know this is an old topic now, but has anyone tried this recently, on 2.4.4? As it doesnt seem to be working for me



  • Not sure if its significant, but I keep seeing lots of 'IGMP message is from myself, ignoring,' and 'IGMP Multicast was local, ignoring' messages in the system log, and a cap on the IPTV_WAN interface, is showing basically no traffic

    Nov 7 18:41:21 igmpproxy 46169 RECV V2 member report from 192.168.4.2 to 234.81.130.125
    Nov 7 18:41:20 igmpproxy 46169 RECV Membership query from 192.168.4.1 to 224.0.0.1
    Nov 7 18:41:14 igmpproxy 46169 The IGMP message was local multicast. Ignoring.
    Nov 7 18:41:13 igmpproxy 46169 The IGMP message was from myself. Ignoring.
    Nov 7 18:41:13 igmpproxy 46169 RECV V2 member report from 192.168.4.1 to 224.0.0.2
    Nov 7 18:41:12 igmpproxy 46169 RECV V2 member report from 192.168.4.2 to 234.81.130.251
    Nov 7 18:41:11 igmpproxy 46169 RECV V2 member report from 192.168.4.2 to 234.81.130.125



  • Works fine for me on 2.4.4



    1. Add the extra interfaces
    2. Enable IGMP proxy & configure
    3. Set interface IP's & configure firewall rules

    Just like above.



  • @perlenbacher Yes, sorry for not getting back quicker. I had it all set right in pf. It looks like the Draytek 130 modem I had in front of it wasnt passing the traffic through correctly. Put an old openreach modem in front instead, and it all sprang to life with the pf config I got from here. So not a pfsense issue. Thanks for confirming that it works for you though :)



  • This is how you set the Vigor 130 for BT multicast IPTV:

    alt text



  • @perlenbacher Thanks. I did get the draytek working after that, by switching it to MPoA, rather than PPPoE as it is by default, but it was still a little strange. The IPTV interfaces in pf both reported around double the traffic level with the draytek as they do with the openreach modem. it should be between 25-30mbps for the BT 4k stream, which is what pf shows with openreach modem, with the draytek, it reports 50-60mbps, and definitely seems to show more signs of picture breakup. So just back to using openreach one for the moment



  • I followed this guide to the t and I still could not get my BT box to even connect to the internet.

    I eventually found it was because of IPv6. I disabled the DHCP server for IPv6 and changed my LAN interface to have "none2 for the IPv6 config type.

    I hope this helps someone :)


Log in to reply