Problem trying to install - pics provided.. **URGENT**

  • Trying to install Pfsense from USB stick and keep hitting this error?

    Tried CD rom boot but thats giving other issues,

    Any ideas?

    My network is currently down and causing absolute mayhem!…

    thanks in advance!

  • From an USB stock (== some sort of emulated CD rom) or a CD-rom …. ok.
    Nice that we know what media you are using to install from.
    You are installing pfSense on what ?
    (please, don't tell me that you're trying to install to the same USB od CD … )
    It should be a normal hard drive,
    Or some flash drive,
    Or, why not, a SSD drive.

  • Thanks for the reply, I'm trying to install to this..

    2 new ssd's in RAID1 config and it wont install (coming up eith errors in the screenshot)

    I'm wondering if its because the drives haven't been wrote to before, so im trying to install ubuntu desktop to them first then will try pfsense over the top as an overwrite.

  • @hardingnick:

    … trying to install ubuntu desktop ....

    Knowing that pfSense is based on Freebsd (not related to Linux ( Ubuntu) at all), why not installing a native Freebsd first to see if it recognizes your Raid1 (bios) config ?

  • I have previously tried windows 7, and it only found the usb drive (itself) as a drive, it installed ubuntu desktop but not to the raid, it installed on the outside of the raid and broke the raid.

    Why would it not see my raid? both drives show as a healthy raid?

  • But you did read what was posted in your other thread, didn't you?


    Then install pfSense with two separate disks- the installer will give you the option to create a mirror.
    You have to use the advanced, not quick install option.

    Your photo shows "easy_install" which IMHO is the quick install option…

  • @hardingnick:

    … both drives show as a healthy raid?

    "Healthy" is (probably)  what the bios says when it's booting.
    Nice to know that the bios supports the raid - it's own setup. But when a vanilla OS doesn't you should probably check out the bios manual to know what need to been done so an OS recognizes the raid.

  • Rebel Alliance Developer Netgate

    It's saying the capacity is "nil" which means nothing. Like it sees the controller but not the disk attached.

    Break the RAID in the BIOS and let pfSense do it using the gmirror option in the installer. You might have to disable RAID in the BIOS or, depending on the controller, put it into some kind of JBOD or similar mode.

    Or install a 2.4 beta image and use ZFS to setup a mirrored set of drives.

  • I did what was recommended. Removed the raid in bios and did a gmirror in the installer. Working a treat, thanks chaps! My Modem arrived earlier so I've got all the settings in place for the swap over later this evening, hoping it will go smoothly. Will let you know :D

    Enabled the CPU tempreture built in widget and its showing theres no values? any ideas? It isn't connected up to the wan yet so not sure if its gonna pull some files down once its connected along with some updates? (i hope its as easy as that)

Log in to reply