Permanently Disable radvd



  • So I moved my pfsense box off the edge but would like it to still handle other tasks on the local network.
    However, it turns out radvd is still running on the box which has been interfering with my IPv6 routing on my network. I've been poking around in the configs but can't find a place to disable radvd. I can turn it off in services, which does work (after I killed the watchdog rule for it) but it gets re-enabled after a reboot and kills IPv6 routing again.

    How do I permanently turn off radvd on pfsense?
    I'm not running any DHCPv6 bits, my pfsense box gets its address via SLAAC

    Thanks!


  • Rebel Alliance Global Moderator

    turn it off on the dhcpv6 tab RA




  • That option isn't available for me. DHCPv6 services page complains: 'The DHCPv6 Server can only be enabled on interfaces configured with a static IPv6 address. This system has none.'

    I tried setting a temporary static v6 address on the WAN interface (disconnected) just to get the settings page to appear for me and router is mode is already set to disabled. I guess that only applies to the WAN interface.

    Anything I can do, aside from setting a static address on my LAN interface and trying that way?


  • Rebel Alliance Global Moderator

    what version of pfsense are you running?



  • 2.3.4-RELEASE-p1


  • Rebel Alliance Global Moderator

    You must of had it running at one time on your lan side interfaces.. So just put a static ipv6 enable dhcp6 and then make sure RA is disabled.  Then disable dhcpv6 on the interface and remove your static IPv6 on it and set it back to none.



  • Thanks! That did it. Once I changed the routing setting for the LAN interface, the radvd service is gone from the list of services in the web interface now.

    Thanks for the help!