• I just figured out why the DHCP on my WLAN didn't work and it looks like a bug to me.

    I just reinstalled pfSense on a new box. I enabled DHCP ( -> 69) on the LAN and pluged in my laptop. It worked great and I could start configuring everything. First I setup the WLAN (wireless) with WAP/WEP (the works) and enabled DHCP on that ( -> 69). I then started the wireless interface on my laptop and it just worked! (me happy).

    And as the wireless connection worked great I unpluged the LAN fom the laptop and pfSense box.

    Then after some time I lost my IP address, guess it expired? And I could not get a new, I reboted (both pfsense and the laptop), "ipconfig /release" and "ipconfig /renew" and nothing worked. Only way I could get back in was by giving the wireless connection a static IP.

    Then I noticed that in the DHCP log it said "dhcpd: vr0: not found", That is my LAN interface I then pluged in the LAN again and WOHOO my wiireless connection could again get an IP assigned ?

    I then disabled DHCP on LAN (vr0) as I'm not going to connect it until I'm done setting it up, and now DHCP on WLAN works even when there isn't connected anything to LAN.

    Can it be right that DHCP on WLAN (opt1) is disabled when the LAN connection is down? Imagne if the switch between pfSense box and the LAN users was turned off by accident, then the WLAN users would get disconnected too.

  • I did a little testing and actually the DHCP server dies completly if there is "no carrier" on LAN when DHCP is enabled on LAN.
    Could only see dhclient when I did a "ps -ax | grep dhc" and after I disabled the DHCP server on LAN I could also see dhcpd was running.

  • What version are we looking at? I have a WRAP running with DHCP on WAN, LAN is disconnected, OPT1 is not configured, OPT2 is an atheros wifi. DHCP is configured at LAN (usually disconnected) and OPT2 (wireless). I don't see this issues. OPT2 DHCP-Server work just fine.

  • pfSense 0.92 the WLAN is a DWL-G520

  • 0.92 was pulled due to bugs. Can you test an image from http://pfsense.com/~sullrich/ (if you're keen as this is prealpha but I guess that you are as you run a pulled version  ;D ) ot try 0.90 from the mirrors?

  • lol didn't know it was pulled , because I had some issues with 0.88 and was told to upgrade I just selected the latest one when I downloaded it.
    I'll give 0.93 a go and report if I find anything, if it too buggy I'll try 0.90.

    I was wondering why DHCP server isn't listed on the "Status -> services" page? I that only in 0.92 or shouldn't it be there at all or did someone just forget to add it :)
    It would be nice to be able to see if it is running without having to go into console and do a "ps -ax | grep dhc"

  • check presence of "dhcpd" by running "top" at diagnostics>command