Problema com NAT



  • Ola,

    Nesse momento a empresa esta a mudar a rede de comunicação de linha adsl para fibra óptica. Estamos a tentar imigrar todos os serviços que temos na nossa rede da linha adsl para fibra óptica. Mas infelizmente não estou a conseguir passar alguns serviços para a fibra óptica, nomeadamente um servidor web que é acedido externamente. Cheguei a parte das regras de firewall e NAT, até agora ja passei dois dias a volta disto mas ainda não consegui nada ….

    Minha estrutura é a seguinte.

    WAN (wan)      -> v4: 192.168.1.97
    LAN (lan)          -> v4: 172.16.0.250
    Gateway            -> v4: 192.168.1.254 que provem do router através da ligação da fibra óptica

    A minha interface WAN esta configurada para modo de DHCP, que recebe o endereço ip do router (192.168.1.97). PFsense não é o meu gateway principal, mas consigo aceder a internet através da interface wan, mas quando tento aceder o meu servidor web externamente, não consigo abrir a porta.

    A minha configuração de NAT:

    interface:WAN
    Protocol:TCP
    Source address:any
    Source Ports:Any
    Dest. Address:WAN ADDRESS
    Dest. Ports:8080
    NAT IP:192.168.0.250
    NAT PORTS: 8080
    NAT Reflection: use systems default
    Filer rule association: add association filter rule

    e fiz algumas configurações no nat, firewall->Advanced->NAT->

    NAT Reflection mode: pure NAT
    Enable NAT:check
    Enable Automatic outbound:check

    por favor alguém poderia me ajudar porque da minha regra não esta a funcionar?



  • @avarela:

    A minha interface WAN esta configurada para modo de DHCP, que recebe o endereço ip do router (192.168.1.97). PFsense não é o meu gateway principal, mas consigo aceder a internet através da interface wan, mas quando tento aceder o meu servidor web externamente, não consigo abrir a porta.

    O problema está aqui. Quando o pacote passa pelo nat do pfsense, vai chegar no servidor web com o ip do cliente e o gateway do servidor web vai mandar o pacote para o seu outro gateway.

    Você tem duas opções para resolver o seu problema. Ou você muda o gateway do servidor web ou cria um outbound nat no pfSense para mascarar o ip do cliente web com o ip da lan do seu firewall.


Log in to reply