OPT1 link fails to route during balancing, not during failover or single use



  • Hi, Folks,

    Strange issue here, I'd love to hear if you had any insight.

    I have a standard multi-WAN config. WAN is a speakeasy DSL line, with fixed IP. OPT1 is an ATT DSL line, with dynamic IP, and the modem is doing NAT so that the OPT1 interface sees a static internal IP (192.168.1.xxx).

    What happens is that when pfsense box is set to Load Balance, the traffic that gets routed through WAN passes fine. However, traffic routed through OPT1 gets dropped. I can't ping through that gateway. However, when traffic is rules-based routed through either of the gateways individually, the link is fine.

    Also, from time to time, particularly when the OPT1 link has been used recently, the OPT1 interface does pass traffic for a while, before dropping out.

    My guess is that it has something to do with AT&T's cheapo consumer network access, but I'm a little baffled, and I don't know enough about how the load balancer works internally to really do much checking. Speaking of that, are there any good documents about internal functionality of the load balancer? I'd like to know more about it (even just figuring out the difference between balancing and failover pools.).

    Thanks, Everyone. I'm including parts of my setup XML below.

    Dave

    –--

    
    	 <interfaces><lan><if>xl0</if>
    			<ipaddr>192.168.0.1</ipaddr>
    			<subnet>24</subnet>
    			 <media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan> 
    		 <wan><if>xl1</if>
    			 <mtu><media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype>
    			 <spoofmac><disableftpproxy><ipaddr>xx.xx.xx.xx</ipaddr>
    			<subnet>24</subnet>
    			<gateway>xx.xx.xx.1</gateway></disableftpproxy></spoofmac></mediaopt></media></mtu></wan> 
    		 <opt1><use_rrd_gateway>68.94.156.1</use_rrd_gateway>
    			<if>dc0</if>
    			<descr>OPT1</descr>
    			 <bridge><ipaddr>dhcp</ipaddr>
    			 <spoofmac><mtu><enable><dhcphostname></dhcphostname></enable></mtu></spoofmac></bridge></opt1></interfaces> 
    
    	 <load_balancer><lbpool><type>gateway</type>
    			<behaviour>balance</behaviour>
    			<monitorip>209.85.171.99</monitorip>
    			<name>LoadBalance</name>
    			<desc>Round Robin Balancing</desc>
    			 <port><servers>wan|66.92.42.1</servers>
    			<servers>opt1|209.85.171.99</servers></port></lbpool> 
    		 <lbpool><type>gateway</type>
    			<behaviour>failover</behaviour>
    			<monitorip>66.92.42.1</monitorip>
    			<name>WanFailsToOPT1</name>
    			<desc>Opt1 prefered when WAN link fails</desc>
    			 <port><servers>opt1|209.85.171.99</servers>
    			<servers>wan|66.92.42.1</servers></port></lbpool> 
    		 <lbpool><type>gateway</type>
    			<behaviour>failover</behaviour>
    			<monitorip>209.85.171.99</monitorip>
    			<name>OPT1FailsToWAN</name>
    			<desc>WAN prefered when OPT1 fails</desc>
    			 <port><servers>wan|66.92.42.1</servers>
    			<servers>opt1|209.85.171.99</servers></port></lbpool></load_balancer> 
    
    

Log in to reply