[SOLVED] yet another Plex and pfsense portfoward Q. But different!!!



  • I have seen many posts about port forwarding  and pfsense. I have got the port forwarding working by adding a simple NAT rule to the pfsense port . I can browse my media collection through the browser …However I cannot seem to get it work with the plex app for android!. Any idea what might be going on?



  • If the port is open it is open so it does not make any difference what app/device is trying to access it.  post a screen shot of the port forward rule and did you set plex to manual 32400 port? are you sure the app has your server selected?


  • Rebel Alliance Global Moderator

    Agreed a port forward is port forward is a port forward.. Does not care what device would be accessing said port.  Where you doing it via some nat reflection when you tested it via your browser?

    While have not actually tested this from android.  My one son's TV accessing it via build in plex app, my other son's firestick accessing it.  And I access it all the time via my ios devices…

    Where is your android device when your testing it?  Is it via cell connection, or on some external wifi network, etc.



  • Here is the screen shot of the port forward rule

    And yes I have set plex to manual 32400 port.

    I have a ethernet connection from my  ISP Modem(192.168.0.1) connected into one LAN card(192.168.0.11) on the pfsense box.. the other LAN card(192.168.1.1) on the box connects to a switch. My Plex Desktop (192.168.1.2) is connected to this switch. I have  TV (192.168.1.3) connected to this switch as well

    The ISP modem has a wireless interface as well. So my android phones wifi (192.168.0.6) is connected to it. I can see my plex server if I browse to 192.168.0.11:32400 on a browser on the phone. But plex app on the phone does not find it

    ![Screenshot from 2017-08-17 21-45-15.png](/public/imported_attachments/1/Screenshot from 2017-08-17 21-45-15.png)
    ![Screenshot from 2017-08-17 21-45-15.png_thumb](/public/imported_attachments/1/Screenshot from 2017-08-17 21-45-15.png_thumb)



  • Dude your ISP Modem should be in bridge mode, looks like you are double NATTING


  • Rebel Alliance Global Moderator

    If not in bridge mode, then you need to make sure any forwards you setup on pfsense you also setup on the nat devices in front of it, ie your isp device.

    This can be done on a case by case bases, or you could use the devices dmz host mode so it sends all unsolicited traffic to your public IP on to pfsense "wan" IP 192.168.0.11 in your example.

    " But plex app on the phone does not find it"

    Your plex app is looking for the plex record an your public IP you give to plex, etc.  So in the case when your on your local wifi this would be a NAT reflection and a bad sort of setup.  I really would suggest you bring your wifi behind pfsense, this can be done with another AP or spare wifi router used as AP.  Then turn off wifi on your isp device and as suggested if possible put it into bridge mode so that pfsense gets a public IP on your wan.

    As to a quick fix - just setup your app to use your local IP or fqdn that resolve to your pfsense WANIP vs trying to do it via public.  So when its on your wifi it works.  I have server setup on my ios that is done via local dns storage.local.lan that points to my plex sever local IP.  So when on my local wifi goes local, and when on vpn it works, etc.



  • Yes I can see now that I was in a double nat scenario. Will change that. Thanks y'all for your feeback. Much appreciated!