Android saying "Connected, no Internet"



  • I have an odd problem with pfSense.

    The Android Pixel XL phone connects to the WiFi access point (another router with all routing funtions disabled) and has a static IP with this info:

    IP: 10.0.0.108
    Gateway: 10.0.0.1
    Netmask: 8
    DNS: 8.8.8.8

    pfSense:
    LAN:
    IP: 10.0.0.1

    WAN:
    Paid ISP Static
    IP: xxx.xxx.xxx.233
    Gateway: xxx.xxx.xxx.238

    IPv4 and IPv6 DHCP are disabled because I have a domain controller with DHCP set up already

    The phone can browse the web fine, and can get emails through my onsite exchange server.

    What am I missing here? Kinda new to pfsense, please be nice :)



  • Netmask 8

    WTH is that? Netmask should be a /24 (most likely) or 255.255.255.0



  • This usually means that the phone had trouble connecting to Google servers. Android usually tries connecting to Google 204 to determine if you have internet access. I also get the same problem because I MITM HTTPS traffic on my network, I am planning to fix it when I have time by just excluding the domain.



  • I am not doing any HTTPS traffic inspection. I will check, but I'm pretty sure that wouldn't be turned on as default.

    It turns out, the phone didn't have net connection. It uses cell when it says "Connected, no internet". Once I put it into airplane mode and turned WiFi on, it wouldn't pull up any pages. Oddly enough, it let Hangout messages and Allo messages through.

    That still doesn't explain why my laptop worked fine.

    The other thing I noticed is that the firewall isn't logging any packets from my laptop as allowed or denied. I have turned logging on for all the rules that I'm trying to follow on the log. Another thing, the when the log does show any action from my laptop, it's usually just the web portal itself. Not any page requests.

    I have gone to my wits end with pfSense. Need some sort of help Please