Limiters not working



  • Hi Folks,

    Trying to get limiters to work on pfSense 2.3.4-RELEASE-p1 (amd64) , but no luck. As far as I've been able to find online/searching, I've setup things properly.

    Setup:

    DSL modem –> pfSense (in Virtual Box VM, two interfaces set as WAN and LAN) --> unmanaged switch --> PCs

    Ex. of a limiter I setup:

    ![](https://forum.pfsense.org/Users/tyler/Desktop/Screen Shot 2017-08-18 at 11.32.28 PM.png)

    My firewall rule:

    Action = PASS
    Interface = LAN
    Address Family = IPv4
    Protocol = TCP/UDP
    Source = singe host or alias = ip of pc
    Destination = singe host or alias = ip of pc
    In/out pipe = set to limiter accordingly

    Have tried rebooting firewall after changes, have tried with squid proxy on and off, have tried with rules applied to both WAN and LAN.  Only additional packages installed are squip and status_traffic_tools. Other than that, pretty vanilla setup.

    Any suggestions?

    Thanks,



  • Source = singe host or alias = ip of pc
    Destination = singe host or alias = ip of pc

    This will never work, because will never meet this condition.



  • Ok… suggestions on what I should be setting there? Lets say that I want to set a limit of 5 Mbps down and 2 Mbps up for device with IP of 192.168.1.2.  I've created the limiter with the bandwidth parameters set.... now in the firewall rule, it requires me to set both a Source and Destination as well as specifying the In/Out pipes in the Advanced section of the rule. I (wrongly?) assumed that since I was setting both the In and Out pipes, that I would have to specify 192.168.1.2 as both source and destination?

    EDIT:::  So it appears that setting the device in question (ex. 192.168.1.2) as the Source, and set Destination to "any" does the trick!

    Thanks to w0w for pointing out my error!