PFSENSE Gateways "Pending" While Setting Up OpenVPN

  • Here's my issue. I've been at this for two days, legit, two days straight, hours and hours on end, just trying to get my pfsense box to connect to the OpenVPN server I have hosted elsewhere. I've got everything working, when I go to /status_openvpn.php, everything is up/up. All good. But when I try to get the gateways to switch over, nothing comes up. In fact, ANY of my gateways that utilize the OpenVPN interface simply say "Pending" constantly. I can't figure out what the issue is, and an expert with pfsense who is trying to help me also can't figure it out.

    You guys got any solutions here please? Google is coming up dry and just….I'm so incredibly frustrated that pfsense doesn't have an actually sensible way to get openvpn operating correctly. UGH!!!

  • I may be wrong, but I believe that I have run into the same issue, and it has to do with the dpinger process(es) responsible for gateway monitoring not being spawned when they should be after a new OpenVPN client connection is established and assigned to an interface.  If you are experiencing the same issue that I have seen, you ought to be able to provide the system with a friendly reminder to spawn dpinger by doing the following once your OpenVPN client connection is up and running:

    • Go to System > Routing

    • Select Edit Gateway for the gateway corresponding to the OpenVPN client connection in question.

    • Click Save, and then click Apply Settings.

    This presumes of course that you have already gone through the configuration for gateway monitoring of the gateway corresponding to the OpenVPN client connection.  Unless you're fundamentally missing some configuration, these steps ought to result in a dpinger process being spawned such that your gateway status will be correctly shown afterward.

  • I‘m ashamed to tell this but after setting up the clients, the interfaces, the gateway and the Nat-rule I simply reboot the firewall. Not a valid enterprise option but at home …

    It always does the trick, even when I have to rectify some errors after the reboot.

Log in to reply