PfSense fatal error unable to create lock file bad file descriptor (9)



  • Hey guys, I'm staying at a hot springs that has a wireless network setup with 6 AP's and a server running pfSense to handle the firewall.
    Every night the system resets (powers down and up again) at 4am, yesterday when the system reset the entire network went down, they use DYNDNS and had just recently re-upped and changed the password for the account. when i got access to the server (just a 4 yearold dell covered in dust on a shelf in the back) I can't use any of the options displayed because fatal error unable to create lock file bad file descriptor (9) keeps popping up. The server also set itself to read-only some how. I've tried https://forum.pfsense.org/index.php?topic=111872.0 and it won't let me mount anything. can anyone offer some assistance?


  • Netgate

    My guess, given the limited amount of information, would be a dead/dying disk.

    Reboot
    Select single user mode from the logo menu
    let it boot
    Press return for /bin/sh
    /sbin/fsck -y /
    If that fsck actually runs, run it about four more times.
    If it dies not run cleanly, it will matter that it is telling you so you'll need to report that. Whatever the issue the quickest solution is going to be backup, reinstall, restore. The configuration file will be in /cf/conf/config.xml. That's generally the file you will need to salvage.

    If it does clean up, /sbin/reboot
    Cross your fingers

    Things like the version they're running would be helpful there.



  • I don't have access to the server right now (cuz business hours) from what i remember they are running PFSense 2.3.2.
    is it possible to take the server out completely and replace it with a managed switch? 
    If it helps the only thing I have access to is the shell and the filter logs


  • Netgate

    No idea, man. Nowhere close to enough information.



  • What would I need to give you?
    I'll see if I can get it


  • Netgate

    No idea what it is they are doing there. A description of the network would be a good start. For instance I have no idea how you might think a firewall can be replaced by a managed switch.



  • wow, my post doesnt make sense.

    ok so i ran fsck and found the disk has a segmentation fault.
    So how do i use the shell to download a back up to a cd or usb?



  • @Xerant:

    ok so i ran fsck and found the disk has a segmentation fault.

    Memory, also known as RAM, can pop up segmentation faults. Not disks …

    @Xerant:

    wow, my post doesnt make sense.

    I'm glad you said that.



  • Yeah, lack of sleep and caffeine don't make for a cognizant mind.
    So it may be bad memory? I'm still trying to figure out why its in readonly mode, and whoever set this up put permission on file transfers so i can't get access to the backup. The bios diag came back all clear on the memory/ram.  Look like a complete reinstall is in order.
    Now if I'm doing a full reinstall on a new HD (got a sandisk SSD) I should be able to pull the config file from the old HD through the pfSense installer right?