Changing the Gateway for one Machine not working anymore.



  • Not sure if this goes in the OpenVPN area or this area as i am not sure where the problem is or the change needs to be made to fix it.  What i am trying to do is route all traffic from one IP to my VPN Gateway (OpenVPN).  I did have this working in the past however with an update (not sure when) it looks to have stopped working.  I am running the latest version and below is how i used to have it done

    Firewall -> Rules -> Lan
    Advanced Options: Gateway:  Change this to the VPN Gateway.

    When i do a package capture on the "LAN" and "VPN" interface i see traffic going out however i see nothing coming back.



  • Maybe the outbound NAT rule was blown away when upgrading pfSense.

    When you route out traffic to the vpn interface, there must exist an outbound NAT rule for the vpn interface translating the source address to the interface address.
    Is this rule still there? Have you changed any network settings?



  • Sorry for the slow response..  The outbound route are still in place.  No network setting have changed other then updating.



  • @pbarbeau:

    When i do a package capture on the "LAN" and "VPN" interface i see traffic going out however i see nothing coming back.

    Now, which source address do you see on vpn interface? If it's your vpn client IP your site is fine and you should look for the reason at servers site.



  • I have the same issue. i think there is a bug in "policy base routing".

    when you add a rule to "any" destination to change the gateway, it will not work. if you set a specific destination for that rule, it will works.

    you can add your rule with "!1.2.4.5" destination to change your client GW till pfsense team fix it.