Pfsense daloradius db login issue



  • Hi everyone,

    I am a huge fan of pfsense and have been using it for more than 2 years now. Recently there have been plans on changing the auth of freeradius from voucher to user based authentication.

    I came across daloradius 0.9.9 and gave it a try but have been stuck for about a week now trying to get it to work. Basically the issue is with the DB abstraction layer not working properly.

    Fatal error: Class 'DB' not found in library/opendb.php on line 86
    

    From within FreeBSD (php5.6), I tried to install everything that was said to be necessary but didn't work. I tried setting up daloradius on a linux box (php5.6) and was getting same errors until I used this command:

    apt-get install php-db
    

    I have been trying to look up the version of this extension in FreeBSD but have been unsuccessful. Does anyone have any idea how I can fix this? Anyone really been able to successfully integrate daloradius with freeradius2 pfsense2.3.4?

    Any help will be greatly appreciated.

    P.S. I also tried the following and they didn't work:```
    pear install DB

    pear install MDB2
    

    pkg install php-dba

    
    Also tried pointing to the absolute path ofthe pear/DB.php file and I only get a blank login.php page when I do that.