Installing 2.4.0RC on HyperV Gen2



  • Hi All,

    I'm trying to install pfsense 2.4.0RC into a HyperV Gen2 VM.  HyperV is running on MS Windows 10 Enterprise build 1703.  Is this a configuration that is supposed to work?

    I am seeing the boot console from the ISO installer for 64bit amd64, fail halfway through startup.  There are messages about device da0 being destroyed ('periph destroyed') while is soon followed by a stream of 'vm_fault: pager read error' messages for pid 1 (init).  The VM is hosed a this point and I have to turn it off.

    My VM is a Gen2 HyperV VM, with 1Gig or RAM allocated and 2 network interfaces.  Secure boot and TPM are also turned off.

    I am hoping it is just a boot config change or something that is easy to change.

    Thanks!

    DT



  • The short answer is that pfsense doesn't use a version of freebsd that supports generation 2. It's on the list for 2.4.1. If you search this forum for this topic, you will find posts about it.



  • Thanks for the info.

    While I did search for info on this topic, I did not use the correct terms as I was under the mistaken impression that it was already a capability as per the documentation page describes how to install pfsense into virtual environment.  However, that may be a Windows Server 2016 thing only and not working for the 'non-server' version s of Win 10.

    In any case, does anyone have a sense as to the lead time before 2.4.1 (and implicitly, FreeBsd 11.1) will be released with HyperV Generation 2 VM support (or is there a roadmap)?  I'm scoping out firewalls for a virtual deployment project and hope to be able to figure out how to plan for it.  Most of the mentions are fairly open as to when 2.4.1 might happen.

    Thanks in advance for any info you guys might have.

    DT



  • You can ask when 2.4.1 will be released, but don't expect an answer, because 2.4.0 hasn't even been released yet. I briefly had 2.4.1 development running before I downgraded it to 2.4.0 RC. It was running on freebsd 11.0. As far as I know, 2.4.1 will use freebsd 11.1 which supports generation 2 vms, but you will have to wait for the change to be made to the development version. I and many others are running pfsense on hyper-v with generation 1 vms. It works fine.



  • Heh.  That's a good enough answer :).

    I just need some idea of what to expect to be able to put together.  I'm already doing all my prep work on Gen 1 VMs, so it should be a trivial switchover to a Gen2 VM when the time comes.

    Thanks for the information and I'll keep an eye out for 2.4.1.

    –DT



  • You're not alone wanting generation 2 VM. I'm going to run 2.4.0 RC for a while on my test system but will probably switch over to 2.4.1 development fairly soon.



  • If you want to get on the 2.4.1 bandwagon, take a look at this: https://www.netgate.com/blog/pfsense-2-4-0-rc-now-available.html. You will be able to get to freebsd 11.1 by tracking this release, but it will require a reinstallation to switch over to a generation 2 vm.



  • I will be keeping an eye out for 2.4.1 with 11.1.

    Thanks again for the info, though  It was helpful.

    –DT


Log in to reply