Squid is blocking access through IPsec tunnel between 2 firewalls



  • Hello all,
    Hoping someone can help me with this. I have two pfSense appliances running version 2.3.4. I needed to connect a remote location, that only has access through an internet connection, to our main servers and company services so I created an IPsec tunnel which has been working for a year now flawlessly. I decided I wanted to install Squid on our larger 1541 appliance that controls the bulk of our users internet connections. I left the majority of the Squid settings to default with the exception of the cache size and available ram assigned to Squid. The issue I am having is that when I enable Squid on the 1541, I loose the ability to connect to my remote pfSense appliance through the IPsec tunnel? I am running a layer 3 network with 5 different subnets and both appliances are attached to my management VLANs under different subnets. As soon as I disable Squid, I am able to gain connection through the tunnel again. What setting am I missing in Squid to unblock access to the other pfSense appliance remotely? Thanks for your help!