Load Balancing Monitor Ip



  • In BETA-2  i used to be able to set a monitor ip under Load Balancer: Pool: Edit in BETA-4 this field is greyed out. If i click on gateway instead of server in the pull down menu type i can set a monitor ip. Is the correct? Have you changed this setting. I upgraded from Beta-2 to Beta-4 and restored my old settings everything else seems to work.



  • It only greys out the type of monitor (TCP or ICMP) as it uses ICMP by default. Monitor and Gateway IP pairs are still needed.



  • Thats my problem it doesn't grey out the option monitor it greys out the option monitor ip. I imported my settings from beta2 could this be the problem. Should i add  my settings manually or is it ok to import my settings from an older version of pfsense.



  • In general it should be ok but under this condition I recommend deleting everything and creating it from scratch by hand. Also make sure you have a healthy beta4. Something is wrong if it greys out the wrong field.



  • @wizard:

    In BETA-2  i used to be able to set a monitor ip under Load Balancer: Pool: Edit in BETA-4 this field is greyed out. If i click on gateway instead of server in the pull down menu type i can set a monitor ip. Is the correct? Have you changed this setting. I upgraded from Beta-2 to Beta-4 and restored my old settings everything else seems to work.

    Monitor is only used for gateway type pools.  Server pools use the server address and port you put in the pool.  For gateways, you may not actually want to monitor the gateway itself, so we provide a monitor ip field so you can choose a different IP to ping.  And yes, b2 -> b4 had numerous LB related changes.

    –Bill


Log in to reply