No internet access [solved!]



  • I am trying to setup a Pfsense router on my laptop using a USB ethernet  and the built in LAN.  So far Pfsense has been able to recognize both internet interfaces.  I am able to get an IP from my ISP and LAN is setup as the default 192.168.1.1/24.  I have gone through the wizard and setup with all default settings.  I am using 8.8.8.8 for the DNS with the check to use the ISP DNS if this fails.

    When I try to access the internet through my browser (Firefox and Internet Explorer Win10) I get no access to the internet.  But when I ping 8.8.8.8 from command line I get a reply.  I have tried from two different PC's both Win10 and get the same problem.  Otherwise these two machines have no problems when connected to my current router.  Funny though windows Network icon will say I have internet access.  I have turned off Windows Firewall, and stopped all anti-virus software.  Pfsense firewall rules are all default.

    I have also tried to reverse the WAN and LAN interfaces as well.  First UE0 to WAN and RE0 to LAN then reverse but same issue.  Also tried Factory reset a few times but still the same.

    This is my hardware specs below…

    Toshiba Satellite A660-0DL Core i3-370M
    Built-in LAN chip  = Realtek 8101/2/3
    USB Ethernet      = AX8872B

    Any help, tips or hints will be appreciated.

    thx....

    thanks to this post.....

    https://forum.pfsense.org/index.php?topic=119077.msg659443#msg659443 from Lucky06480

    Valid (tick) "Disable hardware checksum offload" resolved my problem"
    in [System / Advanced / Networking]



  • Try going back to the default DNS settings as a resolver instead of using google DNS. That's the way it works without you changing any settings.

    Check to see if your clients are getting DHCP leases.

    Using USB & Realtek NICs are both not recommended. The Realtek should be fine for low speed applications - the USB NIC, who knows. It could be your problem right now.

    A better way to use you laptop for pfSense would be with a very basic & cheap web managed switch with 802.11x VLANs.

    https://www.amazon.com/TP-Link-Gigabit-Ethernet-Managed-TL-SG105E/dp/B00N0OHEMA/ref=sr_1_2?s=pc&ie=UTF8&qid=1503616430&sr=1-2&keywords=web+managed+switch&refinements=p_n_feature_keywords_two_browse-bin%3A7306161011