Package Zabbix Proxy 3.4



  • Zabbix 3.4 is released ! Problem :

    Both Zabbix 3.4 proxies and Zabbix 3.4 server are supported to work only with Zabbix 3.4 server and Zabbix 3.4 proxies respectively

    Is it planned to update this package which is currently in 3.0 ?



  • God I hope so…



  • UP.

    I think 3.2 is still not available so 3.4…
    Do you know if we can help pfsense team to developp this module? Where?

    Regard.



  • All versions of Zabbix with Active Support are available in pfSense Beta (2.4.1 / 2.3.5).

    zabbix-agent    Zabbix LTS 3.0 (Current version)
    zabbix-agent22 Zabbix LTS 2.2
    zabbix-agent32 Zabbix Standard 3.2
    zabbix-agent34 Zabbix Standard 3.4

    zabbix-proxy    Zabbix LTS 3.0 (Current version)
    zabbix-proxy22 Zabbix LTS 2.2
    zabbix-proxy32 Zabbix Standard 3.2
    zabbix-proxy34 Zabbix Standard 3.4

    All packages will share the same config.

    More info about Zabbix Releases: https://www.zabbix.com/life_cycle_and_release_policy.

    Please test. Any problems, let me know.

    Regards.



  • @dbaio:

    All versions of Zabbix with Active Support are available in pfSense Beta (2.4.1 / 2.3.5).

    zabbix-agent    Zabbix LTS 3.0 (Current version)
    zabbix-agent22 Zabbix LTS 2.2
    zabbix-agent32 Zabbix Standard 3.2
    zabbix-agent34 Zabbix Standard 3.4

    zabbix-proxy    Zabbix LTS 3.0 (Current version)
    zabbix-proxy22 Zabbix LTS 2.2
    zabbix-proxy32 Zabbix Standard 3.2
    zabbix-proxy34 Zabbix Standard 3.4

    All packages will share the same config.

    More info about Zabbix Releases: https://www.zabbix.com/life_cycle_and_release_policy.

    Please test. Any problems, let me know.

    Regards.

    Is it possible to get Zabbix 3.4 Agent and Proxy to current stable branch?



  • It's available now (2.4.0 / 2.3.4).



  • Hiya,

    How can you install zabbix proxy 3.4 on 2.4.1-RC. I just updated my pfsense to 2.4.1-RC and I still can`t see zabbix 3.4 proxy :-(

    I see this other post so unsure if proxy 3.4 is available or not for 2.4.0 or 2.4.1-RC

    https://forum.pfsense.org/index.php?topic=138327.0

    rajbps



  • @rajbps:

    Hiya,

    How can you install zabbix proxy 3.4 on 2.4.1-RC. I just updated my pfsense to 2.4.1-RC and I still can`t see zabbix 3.4 proxy :-(

    I see this other post so unsure if proxy 3.4 is available or not for 2.4.0 or 2.4.1-RC

    https://forum.pfsense.org/index.php?topic=138327.0

    rajbps

    hi,
    I do have 2.4.0 and can now see both proxy and agent 3.4.



  • Hello,

    I have installed zabbix agent 3.4 and zabbix proxy 3.4 on my PfSense.
    The problem is my agent can't communicate with my proxy.
    Error message:

    
    74968:20171103:095049.030 active check configuration update from [127.0.0.1:10051] started to fail (cannot connect to [[127.0.0.1]:10051]: [4] Interrupted system call)
    
    

    You can find in attachment my configuration.

    I have tried to reinstall both agent and proxy, replace 127.0.0.1 by private ip (172.16.x.x) but nothing seem to work.

    Regards.




  • This was fixed with 1.0.1 version of proxy