WAN connection dies during large Dropbox sync



  • Hi,

    The WAN connection (connected to the ISP router) consistently dies during a large (150 GB) Dropbox sync from a laptop connected to the LAN after every say 10 GB of Dropbox traffic. I can still login to the management interface through the LAN interface when this happens, but I can no longer ping the ISP router (also from the management interface). Stopping and starting the WAN interface does not resolve the issue, only a reboot. If I connect the laptop directory to the ISP router the Dropbox sync finishes without problems.

    How can I further troubleshoot this issue to find the root cause?

    Regards,
    Gijsbert



  • What is your setup? nic cards, hardware, is your modem in bridge mode?



  • I have the same problem, everything has been fine for several years and in the last 2 weeks suddenly heavy internet use causes the PPPoE connection to fail. When it disconnects the system sits reconnecting forever - nothing in the system logs of dmesg indicates any real problems - but the PPPoE connection will not re-establish until the system is rebooted.

    The Machine is an IBM NetVista it has 3x D-Link 528TX cards in it, the Modem is a Vigor 130 connected to VDSL. The machine does not have a lot of RAM in it - but it's never been a problem, until the last few weeks it was perfectly happy coping with simultaneous Netflix streams and serving streams to remote users over Plex. The only real change I can see is that BT has started supplying IPv6 addresses along with the IPv4 addresses. The state table, mbufs and RAM all remain within the normal levels when the connection dies, but the system load goes very very high.

    A reboot brings the connection back and the system load stays around 0.25.

    I tried disabling the OPT interface which provides access to the management of the modem, which brought back the internet connection for a short time - I thought it had fixed it, but when it died again I tried disabling and re-enabling the WAN interface - which also worked, but only after going in to the interfaces page and clicking on Connect - without performing the last step it will just sit in a forever loop claiming it's trying to connect but constantly timing out.

    I don't know if the LAN card is the problem, the PPPoE service or something else. The LAN side of the box has never had these problems and copes with some very busy traffic without issues.

    I'm trying to build a new box with Intel cards in the hope it might fix the problems, and I'll do a completely fresh install to try that, there are NO packages installed - I've gradually removed them all to make sure they were not the problem, and no VPN options are in use.

    Relevant entries from Dmesg:
    fxp0: <intel 100="" 82801ba="" cam="" (ich2="" 3)="" pro="" ethernet="">port 0x70c0-0x70ff mem 0xfebff000-0xfebfffff irq 20 at device 8.0 on pci1
    rl0: <d-link 10="" dfe-530tx+="" 100basetx="">port 0x7400-0x74ff mem 0xfebfee00-0xfebfeeff irq 21 at device 13.0 on pci1
    rl1: <d-link 10="" dfe-530tx+="" 100basetx="">port 0x7800-0x78ff mem 0xfebfef00-0xfebfefff irq 22 at device 14.0 on pci1
    rl0: link state changed to DOWN
    rl1: link state changed to DOWN
    fxp0: link state changed to DOWN
    ng0: changing name to 'pppoe0'
    rl0: link state changed to UP
    rl1: link state changed to UP
    rl0: link state changed to DOWN
    rl0: link state changed to UP
    ng0: changing name to 'pppoe0'
    <snip>sa6_recoverscope: embedded scope mismatch: fe80:8::d859:6de8:bd33:5c1%-1027171676. sin6_scope_id was overridden.sa6_recoverscope: embedded scope mismatch: fe80:8::bc59:6de8:a346:cfc0%-1025639296. sin6_scope_id was overridden.

    Hmm I see there is an Intel card in there, I might try swapping the WAN to the Intel just for a test.</snip></d-link></d-link></intel>



  • I have to  say  it's realtek issue  I use Intel cards and never have these problems, I download gigabytes of data everyday (fiber 250/15) stream plex to family remotely and my wan never drop once, do your selfs a  favor when building a box and use Intel as much as you can



  • I agree with the Realtek assessment.  I was running a pfSense box that would freeze up randomly.  Root cause, Reaktek chipset on one of the NICs.  Replaced the Realtek chipset and it's been rock solid since.


Log in to reply