Multi-WAN Policy Based Routing not working



  • I tried looking at this in the forums but not getting very far.

    1- I have Multi-WAN with a default gateway and both tiered, the primary in Tier1 which is where I want all traffic to go and the other gateway in a Tier 2 as a fallback.  I have gateway switching enabled.

    Failiver Tier:
    GW_1 = Default - Priority Tier 1
    GW_2 = Failover - Priority Tier 2
    

    2 - I have on the LAN interface a .254 IP address AND I also have a virtual IP address of .43 (had to do that for now)

    3 - I make my firewall rule on the LAN like so:

    Pass > Interface:  LAN > IP4 > here I tried LAN Address, LAN Net, individual IP's, an alias with 2 IP's in it...nothing so far > Destination:  8.8.8.8 (for example) > Under "Advanced Options" for "Gateay" I choose my GW_2
    

    I even tried to choose the failover_gw it created for the failover tier but when I try to "tracert" to a destination IP address out on the Interwebs (8.8.8.8) in this example I still go out of GW_1 and not GW_2.

    Nothing I do seems to do policy based routing through that GW_2 gateway.

    Is it because:

    1 - It's a tier 2 gateway?
    2 - It's because of a routing rule I'm missing
    3 - It's because of something else I'm missing…?

    Any help would be awesome.  I'm scratching my head.

    Oh - also note that I dragged the rule in front of the default LAN rule allowing any * any *.  So it should match that traffic first and route through GW_2 but doesn't seem to!

    Thanks!



  • Another "oh gawd" post from me.  Shesh.  Sorry but maybe this will help someone in the future.

    I had to wait until the states cleared / reset.

    Once that happened…done!  It's working.



  • Manual reset of the states is a good idea when you change your rules in any significant way, Diagnostics > States >Reset States.