Static ARP only works with DHCP Server enabled



  • I know it say right there in the GUI:

    This option persists even if DHCP server is disabled. Only the machines listed below will be able to communicate with the firewall on this interface.

    However, with DHCP server disabled, allowed clients in the static mappings section are still denied. 
    It is only after I enable the DHCP server that the client is allowed.

    This is problematic, because this gateway is a restricted gateway on a network where a primary gateway is handing out DHCP.  So I figure I can enable a second, passive DHCP server by enabling "Deny unknown clients" and "Ignore denied clients."  But I still have to setup a pool, pfsense requires this to enable the DHCP server.  This again is problematic, because I don't have the authority to reserve a pool separate from the primary DHCP server.

    What's the best way to accomplish my goal here?  I want this secondary gateway to only allow hosts in my static map list without affecting the primary gateway and its DHCP service.


  • Rebel Alliance Developer Netgate

    On what version of pfSense?

    I fixed a bug there some time ago ( https://redmine.pfsense.org/issues/6821 ) but I'm not sure that ever made its way back into 2.3.x, it may just be fixed in 2.4.


Log in to reply