• Hello,

    We have a pfsense with 2 disks configured in raid 1 with GEOM Mirrors.

    One disk was bad, we had replaced with a new disk. The sync is stuck at 100 % :

    gmirror status
                    Name    Status  Components
    mirror/pfSenseMirror  DEGRADED  ada0 (ACTIVE)
                                    ada1 (SYNCHRONIZING, 100%)
    
    

    I see that the first disk with smart, we have errors when the firewall has rebooted to replace the second disk failed.

    SMART Error Log Version: 1
    ATA Error Count: 5
            CR = Command Register [HEX]
            FR = Features Register [HEX]
            SC = Sector Count Register [HEX]
            SN = Sector Number Register [HEX]
            CL = Cylinder Low Register [HEX]
            CH = Cylinder High Register [HEX]
            DH = Device/Head Register [HEX]
            DC = Device Command Register [HEX]
            ER = Error register [HEX]
            ST = Status register [HEX]
    Powered_Up_Time is measured from power on, and printed as
    DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
    SS=sec, and sss=millisec. It "wraps" after 49.710 days.
    
    Error 5 occurred at disk power-on lifetime: 20844 hours (868 days + 12 hours)
      When the command that caused the error occurred, the device was active or idle.
    
      After command completion occurred, registers were:
      ER ST SC SN CL CH DH
      -- -- -- -- -- -- --
      40 51 00 00 8c a1 40  Error: UNC at LBA = 0x00a18c00 = 10587136
    
      Commands leading to the command that caused the error were:
      CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
      -- -- -- -- -- -- -- --  ----------------  --------------------
      25 00 00 00 8c a1 12 00      00:51:12.327  READ DMA EXT
      25 00 00 00 8c a1 12 00      00:51:10.264  READ DMA EXT
      25 00 00 00 8c a1 12 00      00:51:08.200  READ DMA EXT
      25 00 00 00 8c a1 12 00      00:51:06.001  READ DMA EXT
      25 00 00 00 8c a1 12 00      00:51:03.954  READ DMA EXT
    ...
    

    So, we will reinstall pfsense soon but we aren't on site.

    Is there a way to unlock this situation please ?

    Thanks.

  • Rebel Alliance Developer Netgate

    Looks to me like that second disk (ada1) has failed. There probably won't be any way around that without physically replacing the drive.