Slow across all nics



  • Hi. hopefully someone can help with this

    motherboard: asrock n3700m with 32gb ram
    motherboard: nic Realtek RTL8111GR    re0
    pcie nic: ibm 49y4242    igb0,igb1,igb2,igb3

    basically im getting very slow speed across all nics.
    using iperf on pfsense, all nics get between 30 Mbits and 300 Mbits depending on window size. this is also the same across sub nets using a ubuntu server on igb3 and laptop on re0

    found this problem on 2.3.4 so updated to 2.3.4_1 no change. tried a clean install, no different, tried a 2.2.6 version. still the same
    on all versions ive increased the mbuf size, disabled checksum,tcp,lro offloading and adjusted flow control . tested before and after each setting was changed
    cpu stays at idle on all cores with minor movement when iperf test runs

    i have tried a Ubuntu install on the system and get 800-900 Mbits out to the nics on iperf on default settings so I'm pretty sure its not the hardware

    any ideas would be greatly appreciated



  • Get rid of the Realtek NICs.  They are usually the source of all problems.



  • its normally not used. was using it to see if the intel driver driver was the problem



  • Measure throughput instead of from/to pfsense.



  • i did using a Ubuntu server same results



  • Well I've not solved the problem. but i have a temporary fix. I've replaced the PC it was running on. Restored it with my backup file and runs fine getting correct speeds on all nics


Log in to reply